The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

problem with smtp authentication with phpmail

Discussion in 'E-mail Discussions' started by raystrach, Aug 21, 2011.

  1. raystrach

    raystrach Member

    Joined:
    Aug 21, 2010
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    out of the blue, my phpmailer script stopped working. it has been working well for at least the last 12 months.

    i thought it may have something to do with a cpanel auto update.

    i have scoured the internet to try to find a solution without success. If i disable smtp authentication, it works fine, but i do not want that to be a permanent solution.

    i tried heaps of different variations in the settings and i have tried to tweak some mail settings in whm - all to no avail. i know it is connecting ok but the logins are being rejected.

    coincidentally(or not) ftp login in an upload script stopped working on the same day. i was able to overcome that by changing the ftp address to an ip and took the domain name off the username. another authentication script (connect to cpanel for backup) in a cron job also has stopped working at about the same time.

    i am running the following configuration on linux (centos)

    apache: v 2.2.15
    cpanel:11.30.2 (build 1)
    php: 5.2.15
    phpmailer: 5.2

    i would be interested if anyone else was had this problem recently and what they did to overcome it.

    the only other possibility is that my server host has changed some configurations which is affecting these settings although requests to them for info about this has met with an unconvincing denial about changes

    cheers

    rs
     
  2. minosjl

    minosjl Well-Known Member

    Joined:
    Jun 4, 2011
    Messages:
    168
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Hello,

    Do you have disabled the nobody user send the mails from the server ?
     
  3. raystrach

    raystrach Member

    Joined:
    Aug 21, 2010
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    thanks for the suggestion...

    overnight my server hosts asked me to try "localhost" as the smtp host and it worked!

    this was the one solution i did not try as a number of the posts i read on the subject did mention that this did not work.

    i must admit i thought preventing"nobody" from sending mail only affected sendmail or the php mail() function, not smtp.
     
Loading...

Share This Page