The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem with Spamassasin

Discussion in 'General Discussion' started by strauberry, May 20, 2003.

  1. strauberry

    strauberry Well-Known Member

    Joined:
    Mar 25, 2003
    Messages:
    150
    Likes Received:
    0
    Trophy Points:
    16
    Hi,

    In every message I send with a script I have the following message:

    Message-Id: <E19I2oi-0000cb-00@srv08.edv-sklave.de>
    Date: Tue, 20 May 2003 10:49:52 +0200
    X-AntiAbuse: This header was added to track abuse, please include it with any abuse report
    X-AntiAbuse: Primary Hostname - srv08.edv-sklave.de
    X-AntiAbuse: Original Domain - gmx.de
    X-AntiAbuse: Originator/Caller UID/GID - [99 99] / [99 99]
    X-AntiAbuse: Sender Address Domain - srv08.edv-sklave.de

    I disabled spamassasin in the tweak settings... so why get I this message :confused:

    Thank you!
    strauberry

    cPanel.net Support Ticket Number:
     
  2. strauberry

    strauberry Well-Known Member

    Joined:
    Mar 25, 2003
    Messages:
    150
    Likes Received:
    0
    Trophy Points:
    16
    no one ? :(

    cPanel.net Support Ticket Number:
     
  3. howard

    howard Well-Known Member

    Joined:
    Apr 20, 2003
    Messages:
    233
    Likes Received:
    0
    Trophy Points:
    16
    This has nothing to do with Spamassasin they get added to mall regardles if it is enabled or not

    They just allow a admin to see weather it was generated from a web script or weather it was from a mail client (although there is/was spam going around with fake ones)

    cPanel.net Support Ticket Number:
     
  4. strauberry

    strauberry Well-Known Member

    Joined:
    Mar 25, 2003
    Messages:
    150
    Likes Received:
    0
    Trophy Points:
    16
    Hi,

    thank you for your answer! Where can I disable it??

    Thank you again
    strauberry

    cPanel.net Support Ticket Number:
     
  5. strauberry

    strauberry Well-Known Member

    Joined:
    Mar 25, 2003
    Messages:
    150
    Likes Received:
    0
    Trophy Points:
    16
    Hi,

    ok two things: where can I disable the feature, that this header is added and:
    In some Emails I got this header (those, which go to another domain) and in other Emails there is no header (those, which go to a domain on my server). So where's the mistake / problem ??

    It is urgent, I need your help!

    Thank you!
    strauberry

    cPanel.net Support Ticket Number:
     
  6. howard

    howard Well-Known Member

    Joined:
    Apr 20, 2003
    Messages:
    233
    Likes Received:
    0
    Trophy Points:
    16
    sorry for the delay in replying i competly forgot about this thread

    However you can edit /etc/exim.conf and go down to the section called lookuphost:
    which roughly looks like this

    lookuphost:
    driver = lookuphost
    transport = remote_smtp
    headers_add = "X-AntiAbuse: This header was added to track abuse, please includ$
    X-AntiAbuse: Primary Hostname - $primary_hostname\n\
    X-AntiAbuse: Original Domain - $original_domain\n\
    X-AntiAbuse: Originator/Caller UID/GID - [$originator_uid $origi$
    X-AntiAbuse: Sender Address Domain - $sender_address_domain\n"
    condition = "${perl{checkspam}}"

    You just delete to headers_add and all the X-Antiabuse stuff after that

    These headers would only be added if it mail was sent to a domain which was not hosted by your server, so if mail was sent to another domain hosted by your server then the headers would not be added

    cPanel.net Support Ticket Number:
     
  7. strauberry

    strauberry Well-Known Member

    Joined:
    Mar 25, 2003
    Messages:
    150
    Likes Received:
    0
    Trophy Points:
    16
    Hi,

    thank you for this great hint!!! Is it also possible to disable this feature by unchecking a checkbox in the admin-area (somewhere I reat something like "emails from nobody" and so on).

    The strange thing is, that this header isn't added in every mail, only in my own emails :) Not one client complained about this so I guess that there is no header. Is that possible and how??

    Thank you so much
    strauberry

    cPanel.net Support Ticket Number:
     
  8. howard

    howard Well-Known Member

    Joined:
    Apr 20, 2003
    Messages:
    233
    Likes Received:
    0
    Trophy Points:
    16


    No, although i guess you could submit it as a feature request

    Not entirely sure about this one if you made the change to exim.conf did you restart it afterwards

    cPanel.net Support Ticket Number:
     
Loading...

Share This Page