The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem with srm.config

Discussion in 'Security' started by mitro_al, Jun 12, 2006.

  1. mitro_al

    mitro_al Registered

    Joined:
    Jun 12, 2006
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Dear colleagues,

    I have had for a long time the problem with srm.config. This file either was deleted or erased during virus scan. Due to this problem the Hotlink protection is disabled which allows many spams to fill in my Inbox, Frontpage extensions are disabled too, which make my activities going slow.

    These are the notices coming out while trying to reainstall extensions:

    Attempting to install FrontPage extensions...

    Error: The server extensions were unable to access the file "srm.conf". Please check the file permissions.
    Setting Password
    Frontpage passthough auth enabled!


    FrontPage extensions are currently: not installed



    Or Hotlink Protection:

    Apache detected an error in the Rewrite config.

    fopen: Permission denied
    httpd: could not open document config file /usr/local/apache/conf/srm.conf


    . Please try again.


    Can anyone tell me how to reinstall srm.config. I have this file in desktop but i do not understand the location where to install it (/usr/local/apache/conf/srm.conf).


    Sincerely,


    Albert
     
  2. jdlitson

    jdlitson Registered

    Joined:
    Jan 12, 2007
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    I am having the same issue /usr/local/apache/conf/srm.conf .
    I am logged in as root.
    It's not writable.
    I am unable to delete it with rm -rf srm.conf.
    The user:group and file permissions all have question marks.

    Code:
    ls -l
    ?---------  ? ?    ?        ?            ? srm.conf
    
    Same for:
    ?---------  ? ?    ?        ?            ? access.conf
    
    Thanks -Jason
     
Loading...

Share This Page