The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem with system root mails - help

Discussion in 'E-mail Discussions' started by bsasninja, Jan 11, 2008.

  1. bsasninja

    bsasninja Well-Known Member

    Joined:
    Sep 2, 2004
    Messages:
    528
    Likes Received:
    0
    Trophy Points:
    16
    Im having a problem with a new server I setup with system messages, I have 3 other servers that works fine, I receive every night:

    From: Cron Daemon Cron <root@server> /scripts/upcp

    But in the new server I receive it bad:

    From: Mail Delivery System Mail delivery failed: returning message to sender

    The contact manager at whm is configured as the same as the other servers. Dont know why is refusing the message, please see the bounce below.

    My new server is called server.domain.net and all system messages should be sent to other address in other server called server@mydomain.com



    This message was created automatically by mail delivery software.

    A message that you sent could not be delivered to one or more of its
    recipients. This is a permanent error. The following address(es) failed:

    server@mydomain.com
    (generated from root@server.domain.net)
    SMTP error from remote mail server after RCPT TO:<server@mydomain.com>:
    host mydomain.com [x.x.xx.xx]: 550-Verification failed for <root@server.domain.net>
    550-Called: xx.xx.xx.xx.xx6
    550-Sent: RCPT TO:<root@server.domain.net>
    550-Response: 550-You do not have sufficient privileges to send mail to this address. Please
    550-550 authenticate and try again.
    550 Sender verify failed

    ------ This is a copy of the message, including all the headers. ------

    Return-path: <root@server.domain.net>
    Received: from root by server.domain.net with local (Exim 4.68)
    (envelope-from <root@server.domain.net>)
    id 1JDAFc-0002Z1-3n
    for root@server.domain.net; Fri, 11 Jan 2008 00:08:18 -0300
    From: root@server.domain.net (Cron Daemon)
    To: root@server.domain.net
    Subject: Cron <root@server> /scripts/upcp
    Content-Type: text/plain; charset=UTF-8
    Auto-Submitted: auto-generated
    X-Cron-Env: <SHELL=/bin/sh>
    X-Cron-Env: <HOME=/root>
    X-Cron-Env: <PATH=/usr/bin:/bin>
    X-Cron-Env: <LOGNAME=root>
    X-Cron-Env: <USER=root>
    Message-Id: <E1JDAFc-0002Z1-3n@server.domain.net>
    Date: Fri, 11 Jan 2008 00:08:18 -0300

    Checking and Repairing System Package Setup......Done
    Setting up ip startup......Done
    Configuring editors......Done
    Creating symlinks for common binaries......Done
    Setting Clock......Done
    Running Env Auto Repair...quota test: repquota exited with signal 0 (ok)
    Requesting script ... Done
    Auto Repair is running...
    io_compress_gzip has already been run.

    spamd_dbm_fix has already been run.
    ...Auto Repair is done.
    ...Done
    Running Cleanups...Found hostname to be server.unarea.net, which resolves to xx.xx.xx.xx
    Hostname Virtual Host is already setup
    ...Done
    Updating services & databases...PHP version file has been updated to 5.2.5
    Ftp Quota Check v1.6
    ...Done
    Cpanel updates are coming from layer2.cpanel.net
    Setting Up Crontab......Done
    Setting Up dcpumon Crontab......Done
    Repairing Mailman Permissions......Done
    Running Sanity Checks & Notifications...Using smartcheck config 5.32 for smartctl(5.36)
    Checking /dev/sda....S.M.A.R.T does not appear to be enabled for this device.
    Checking /dev/sdb....S.M.A.R.T does not appear to be enabled for this device.
    ...Done
    Running Named Checks......Done
    Restoring compiler permissions...Compilers are disabled for unprivileged users.
    ...Done
    Repairing mysql......Done
    Optimizing Databases......Done
    Added Contact server@mydomain.com
    Scanning for new mail senders.....Done
    Scanning suexec_log...Done
     
  2. Un Area

    Un Area Well-Known Member

    Joined:
    Nov 16, 2006
    Messages:
    78
    Likes Received:
    0
    Trophy Points:
    6
    Im having the same issue, Im using Centos 5.0.

    Any clues?¿?¿?
     
  3. bsasninja

    bsasninja Well-Known Member

    Joined:
    Sep 2, 2004
    Messages:
    528
    Likes Received:
    0
    Trophy Points:
    16
    The only difference I found in the servers is that in this one the smtp tweak setting is enable. This feature can be causing this????

    Thank you!
     
  4. nrm

    nrm Member
    PartnerNOC

    Joined:
    Jan 11, 2007
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Moscow, Russia
    Im having the same issue, Im using Centos 5.0/Fedore 5.0

    How to correct disable this rule in exim.conf:


    :confused::confused::confused:
     
    #4 nrm, Feb 27, 2008
    Last edited: Feb 28, 2008
  5. xprt5

    xprt5 Well-Known Member

    Joined:
    Apr 6, 2003
    Messages:
    72
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Houston
    The option for this is in WHM > Exim Configuration Editor and is called

    ** BL: Reject mail sent directly to addresses at the primary hostname from
    remote servers. [?]

    If you have this option checked then it will add the deny_message in exim.conf
    to not allow email to the hostname.
     
  6. 4u123

    4u123 Well-Known Member
    PartnerNOC

    Joined:
    Jan 2, 2006
    Messages:
    765
    Likes Received:
    1
    Trophy Points:
    18
    I'm sorry to reply to an old thread but I'm having this problem. All mail is rejected when sent to user@server-hostname but I dont have this option enabled..

    Reject mail sent directly to addresses of the primary hostname from remote servers.

    I've reset the exim config on all my servers but this problem still happens.

    The rejection message is as follows...

    I'm not sure about the "while verifying" part of that message either - because we have sender verify disabled too.
     
Loading...

Share This Page