The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

problem with update cpanel

Discussion in 'General Discussion' started by Motamedi, Mar 6, 2016.

  1. Motamedi

    Motamedi Well-Known Member

    Joined:
    Mar 14, 2015
    Messages:
    53
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Iran , Tehran
    cPanel Access Level:
    Root Administrator
    hello

    my problem is update cpanel

    When I updated seen this error

    Error: Nothing to do
    [2016-03-06 18:47:04 +0330] checkyum version 22.3
    [2016-03-06 18:47:05 +0330] E Sysup: Needed system RPMs were not installed: nscd
    [2016-03-06 18:47:05 +0330] ***** FATAL: Cannot proceed. Needed system RPMs were not installed.
    [2016-03-06 18:47:05 +0330] The Administrator will be notified to review this output when this script completes
    => Log closed Sun Mar 6 18:47:05 2016
    [2016-03-06 18:47:05 +0330] 17% complete
    [2016-03-06 18:47:05 +0330] E Running `/usr/local/cpanel/scripts/updatenow --upcp --log=/var/cpanel/updatelogs/update.1457277408.log --force` failed, exited with code 18 (signal = 0)
    => Log closed Sun Mar 6 18:47:06 2016

    please help me for solve this problem

    thanks
     
  2. Jcats

    Jcats Well-Known Member

    Joined:
    May 25, 2011
    Messages:
    275
    Likes Received:
    31
    Trophy Points:
    28
    Location:
    New Jersey
    cPanel Access Level:
    DataCenter Provider
    You would need to post more of the log, can you do:

    Code:
    tail -50 /var/cpanel/updatelogs/update.1457277408.log
     
  3. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,482
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
  4. Motamedi

    Motamedi Well-Known Member

    Joined:
    Mar 14, 2015
    Messages:
    53
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Iran , Tehran
    cPanel Access Level:
    Root Administrator
    i'm by this command update " /scripts/upcp --force "

    and entered this commands Upgrade to Latest Version - Documentation - cPanel Documentation

    but not solve my problem ...

    When the update is still the same error

    [2016-03-06 23:12:45 +0330] Error: Nothing to do
    [2016-03-06 23:12:45 +0330] checkyum version 22.3
    [2016-03-06 23:12:46 +0330] E Sysup: Needed system RPMs were not installed: nscd
    [2016-03-06 23:12:46 +0330] ***** FATAL: Cannot proceed. Needed system RPMs were not installed.
    [2016-03-06 23:12:46 +0330] The Administrator will be notified to review this output when this script completes
    => Log closed Sun Mar 6 23:12:46 2016
    [2016-03-06 23:12:46 +0330] 17% complete
    [2016-03-06 23:12:46 +0330] E Running `/usr/local/cpanel/scripts/updatenow --upcp --log=/var/cpanel/updatelogs/update.1457293355.log --force` failed, exited with code 18 (signal = 0)
    => Log closed Sun Mar 6 23:12:46 2016
     
  5. Motamedi

    Motamedi Well-Known Member

    Joined:
    Mar 14, 2015
    Messages:
    53
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Iran , Tehran
    cPanel Access Level:
    Root Administrator
    Previously, this process was carried out
    But the problem is not resolved

     
  6. Motamedi

    Motamedi Well-Known Member

    Joined:
    Mar 14, 2015
    Messages:
    53
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Iran , Tehran
    cPanel Access Level:
    Root Administrator
    error log is :

     
  7. Jcats

    Jcats Well-Known Member

    Joined:
    May 25, 2011
    Messages:
    275
    Likes Received:
    31
    Trophy Points:
    28
    Location:
    New Jersey
    cPanel Access Level:
    DataCenter Provider
    You're still not showing enough of the log.

    Code:
    # tail -50 /var/cpanel/updatelogs/update.1457277408.log
    Should show enough
     
  8. Motamedi

    Motamedi Well-Known Member

    Joined:
    Mar 14, 2015
    Messages:
    53
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Iran , Tehran
    cPanel Access Level:
    Root Administrator
    Sorry for the mistake

    Code:
    
    root@server53 [~]# tail -50 /var/cpanel/updatelogs/update.1457293355.log
    [2016-03-06 23:12:38 +0330]  Detected version '11.50.5.0' from version file.
    [2016-03-06 23:12:38 +0330]  Running version '11.52.4.0' of updatenow.
    [2016-03-06 23:12:38 +0330]  --force passed on command line. Upgrade will disregard update config settings.
    [2016-03-06 23:12:38 +0330]  Using mirror '94.75.231.77' for host 'httpupdate.cpanel.net'.
    [2016-03-06 23:12:38 +0330]  Successfully verified signature for cpanel (key types: release).
    [2016-03-06 23:12:38 +0330]  Target version set to '11.54.0.18'
    [2016-03-06 23:12:38 +0330]  Target version set to '11.52.4.0'
    [2016-03-06 23:12:38 +0330]  Upgrade requested to a version more than 1 LTS away. Will upgrade to next LTS first (11.52.4.0).
    [2016-03-06 23:12:38 +0330]  Checking license
    [2016-03-06 23:12:38 +0330]  License file check complete
    [2016-03-06 23:12:38 +0330]  Checking that the RPM DB is OK...
    [2016-03-06 23:12:38 +0330]  glibc-2.12-1.149.el6_6.9.x86_64
    [2016-03-06 23:12:38 +0330]  OK: RPM DB is responding to queries
    [2016-03-06 23:12:38 +0330]  Testing if rpm_is_working RPM is installed
    [2016-03-06 23:12:38 +0330]  package rpm_is_working is not installed
    [2016-03-06 23:12:38 +0330]  Testing if it's possible to install a simple RPM
    [2016-03-06 23:12:38 +0330]  Preparing...  ##################################################
    [2016-03-06 23:12:38 +0330]  rpm_is_working  ##################################################
    [2016-03-06 23:12:39 +0330]  Switching to version '11.52.4.0' of updatenow to perform sync.
    [2016-03-06 23:12:39 +0330]  checkyum version 22.3
    [2016-03-06 23:12:40 +0330]  checkyum version 22.3
    [2016-03-06 23:12:41 +0330]  Loaded plugins: fastestmirror, rhnplugin, security
    [2016-03-06 23:12:44 +0330]  Profilename: server53.domain.net
    [2016-03-06 23:12:44 +0330] E There was an error communicating with CLN.
    [2016-03-06 23:12:44 +0330]  Setting up Install Process
    [2016-03-06 23:12:44 +0330]  Loading mirror speeds from cached hostfile
    [2016-03-06 23:12:44 +0330]  No package nscd available.
    [2016-03-06 23:12:45 +0330] E Error: Nothing to do
    [2016-03-06 23:12:45 +0330] E The system failed to execute yum with the arguments “-y -c /etc/yum.conf install nscd” because of an error: The “/usr/bin/yum” command (process 380629) reported error number 1 when it ended. : There was an error communicating with CLN.
    [2016-03-06 23:12:45 +0330] CLN support will be disabled.
    [2016-03-06 23:12:45 +0330] Error communicating with server. The message was:
    [2016-03-06 23:12:45 +0330] Error Message:
    [2016-03-06 23:12:45 +0330]  Please run rhn_register as root on this client
    [2016-03-06 23:12:45 +0330] Error Class Code: 9
    [2016-03-06 23:12:45 +0330] Error Class Info: Invalid System Credentials.
    [2016-03-06 23:12:45 +0330] Explanation:
    [2016-03-06 23:12:45 +0330]  An error has occurred while processing your request. If this problem
    [2016-03-06 23:12:45 +0330]  persists please enter a bug report at helpdesk.cloudlinux.com.
    [2016-03-06 23:12:45 +0330]  If you choose to submit the bug report, please be sure to include
    [2016-03-06 23:12:45 +0330]  details of what you were trying to do when this error occurred and
    [2016-03-06 23:12:45 +0330]  details on how to reproduce this problem.
    [2016-03-06 23:12:45 +0330] Error: Nothing to do
    [2016-03-06 23:12:45 +0330]  checkyum version 22.3
    [2016-03-06 23:12:46 +0330] E Sysup: Needed system RPMs were not installed: nscd
    [2016-03-06 23:12:46 +0330] ***** FATAL: Cannot proceed. Needed system RPMs were not installed.
    [2016-03-06 23:12:46 +0330]  The Administrator will be notified to review this output when this script completes
    => Log closed Sun Mar  6 23:12:46 2016
    [2016-03-06 23:12:46 +0330]  17% complete
    [2016-03-06 23:12:46 +0330] E Running `/usr/local/cpanel/scripts/updatenow --upcp --log=/var/cpanel/updatelogs/update.1457293355.log --force` failed, exited with code 18 (signal = 0)
    => Log closed Sun Mar  6 23:12:46 2016
    root@server53 [~]#
    
    
    
     
    #8 Motamedi, Mar 7, 2016
    Last edited by a moderator: Mar 7, 2016
  9. Motamedi

    Motamedi Well-Known Member

    Joined:
    Mar 14, 2015
    Messages:
    53
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Iran , Tehran
    cPanel Access Level:
    Root Administrator
    With what commands my problem is solved?
    Please teach me complete
    thanks
     
  10. Jcats

    Jcats Well-Known Member

    Joined:
    May 25, 2011
    Messages:
    275
    Likes Received:
    31
    Trophy Points:
    28
    Location:
    New Jersey
    cPanel Access Level:
    DataCenter Provider
    Do you have a valid CloudLinux license first of all?

    Try doing:

    Code:
    # rhn_register
    What does that give you?
     
  11. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
Loading...

Share This Page