The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

problem with upgrades apache and cpanel

Discussion in 'EasyApache' started by robocap, Dec 7, 2006.

  1. robocap

    robocap Well-Known Member

    Joined:
    Nov 6, 2006
    Messages:
    67
    Likes Received:
    0
    Trophy Points:
    6
    Hi Dear,
    i have problem with upgrades apache and cpanel and Server Software

    for exapmle will time that iwant upgrades apache take to me error

    Code:
    Fetching http://layer1.cpanel.net/buildapache.sea (0)....@69.90.250.35......connected......receiving...1%...3%...4%...6%...7%...9%...10%...12%...13%...15%...16%...18%...19%...21%...22%...24%...25%...27%...28%...30%...31%...33%...34%...36%...37%...39%...40%...42%...43%...45%...46%...48%...49%...51%...52%...54%...55%...57%...58%...60%...61%...63%...64%...66%...67%...69%...70%...72%...73%...75%...76%...78%...79%...81%...82%...84%...86%...87%...89%...90%...92%...93%...95%...96%...98%...99%...100%......Done
    Verifying archive integrity... All good.
    Uncompressing buildapache.........................................................................................................................................................................................................................................
    Checking Update System........Your operating system's rpm update method (yum) was not able to locate the glibc package. This is an indication of an improper setup. You must correct this error before you can proceed.
    Please correct the conflicts and try again!
    initfpsuexec: using apache 1.x support
        

    Please help me.
     
  2. robocap

    robocap Well-Known Member

    Joined:
    Nov 6, 2006
    Messages:
    67
    Likes Received:
    0
    Trophy Points:
    6
    Problem with upgrades cpanel

    Hi Dear,
    i want upgrades cpanel but take to me error


    Code:
    Reading repository metadata in from local files
    Traceback (most recent call last):
      File "/usr/bin/yum", line 29, in ?
        yummain.main(sys.argv[1:])
      File "/usr/share/yum-cli/yummain.py", line 97, in main
        result, resultmsgs = do()
      File "/usr/share/yum-cli/cli.py", line 470, in doCommands
        return self.installPkgs()
      File "/usr/share/yum-cli/cli.py", line 836, in installPkgs
        self.doRepoSetup()
      File "/usr/share/yum-cli/cli.py", line 75, in doRepoSetup
        self.doSackSetup(thisrepo=thisrepo)
      File "__init__.py", line 260, in doSackSetup
      File "repos.py", line 287, in populateSack
      File "sqlitecache.py", line 96, in getPrimary
      File "sqlitecache.py", line 89, in _getbase
      File "sqlitecache.py", line 373, in updateSqliteCache
      File "/var/tmp/python-sqlite-root//usr/lib/python2.3/site-packages/sqlite/main.py", line 244, in execute
    _sqlite.DatabaseError: unable to open database file
    Repository update is listed more than once in the configuration
    Repository base is listed more than once in the configuration
    Setting up Update Process
    Setting up repositories
    Reading repository metadata in from local files
    Traceback (most recent call last):
      File "/usr/bin/yum", line 29, in ?
        yummain.main(sys.argv[1:])
      File "/usr/share/yum-cli/yummain.py", line 97, in main
        result, resultmsgs = do()
      File "/usr/share/yum-cli/cli.py", line 477, in doCommands
        return self.updatePkgs()
      File "/usr/share/yum-cli/cli.py", line 955, in updatePkgs
        self.doRepoSetup()
      File "/usr/share/yum-cli/cli.py", line 75, in doRepoSetup
        self.doSackSetup(thisrepo=thisrepo)
      File "__init__.py", line 260, in doSackSetup
      File "repos.py", line 287, in populateSack
      File "sqlitecache.py", line 96, in getPrimary
      File "sqlitecache.py", line 89, in _getbase
      File "sqlitecache.py", line 373, in updateSqliteCache
      File "/var/tmp/python-sqlite-root//usr/lib/python2.3/site-packages/sqlite/main.py", line 244, in execute
    _sqlite.DatabaseError: unable to open database file
    Method: Perl Expect

    and

    Code:
    eading repository metadata in from local files
    Traceback (most recent call last):
      File "/usr/bin/yum", line 29, in ?
        yummain.main(sys.argv[1:])
      File "/usr/share/yum-cli/yummain.py", line 97, in main
        result, resultmsgs = do()
      File "/usr/share/yum-cli/cli.py", line 477, in doCommands
        return self.updatePkgs()
      File "/usr/share/yum-cli/cli.py", line 955, in updatePkgs
        self.doRepoSetup()
      File "/usr/share/yum-cli/cli.py", line 75, in doRepoSetup
        self.doSackSetup(thisrepo=thisrepo)
      File "__init__.py", line 260, in doSackSetup
      File "repos.py", line 287, in populateSack
      File "sqlitecache.py", line 96, in getPrimary
      File "sqlitecache.py", line 89, in _getbase
      File "sqlitecache.py", line 373, in updateSqliteCache
      File "/var/tmp/python-sqlite-root//usr/lib/python2.3/site-packages/sqlite/main.py", line 244, in execute
    _sqlite.DatabaseError: unable to open database file
    Done
    BIND 9.2.4
    please help me.

    Thanks You
     
    #2 robocap, Dec 8, 2006
    Last edited: Dec 8, 2006
  3. mtech-hosting

    mtech-hosting Well-Known Member

    Joined:
    Apr 30, 2006
    Messages:
    62
    Likes Received:
    0
    Trophy Points:
    6
    Nearly the exact same error for me also, any solutions please ?
     
  4. bin_asc

    bin_asc Well-Known Member

    Joined:
    Jul 18, 2005
    Messages:
    280
    Likes Received:
    0
    Trophy Points:
    16
    Simple solution, came across this : umount /var/tmp and run /scripts/securetmp. Might be usefull to someone.
     
Loading...

Share This Page