The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem with upload or create file via www

Discussion in 'General Discussion' started by Mladen Dokic, Jan 11, 2015.

  1. Mladen Dokic

    Mladen Dokic Member

    Joined:
    Aug 6, 2014
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Bijeljina, Bosnia and Herzegovina
    cPanel Access Level:
    Root Administrator
    I have a problem that my users can not through their website created or upload files.

    Over cpanel or ftp they can add or create.

    But for example, if you try to install wordpress, will not be automatically created wp-config.php or via Wordpress Admin try to upload image in Post that they will not be uploaded to the ftp.

    The last thing I worked on the root cpanel, and possibly is associated to this, is the "Easy Apache".

    I enabled: GD, Mbstring, ModSecurity,

    Later, I immediately disabled the ModSecurity thinking that this is a problem, but still not working properly.
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,474
    Likes Received:
    202
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Are you using SuPHP?
     
  3. Mladen Dokic

    Mladen Dokic Member

    Joined:
    Aug 6, 2014
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Bijeljina, Bosnia and Herzegovina
    cPanel Access Level:
    Root Administrator
    No, its disabled
     
  4. Mladen Dokic

    Mladen Dokic Member

    Joined:
    Aug 6, 2014
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Bijeljina, Bosnia and Herzegovina
    cPanel Access Level:
    Root Administrator
  5. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,474
    Likes Received:
    202
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    It would solve this for you.
     
  6. Mladen Dokic

    Mladen Dokic Member

    Joined:
    Aug 6, 2014
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Bijeljina, Bosnia and Herzegovina
    cPanel Access Level:
    Root Administrator
    I am enabled SuPHP and restart Apache, but I still have the same problem.
     
  7. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,474
    Likes Received:
    202
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
  8. Mladen Dokic

    Mladen Dokic Member

    Joined:
    Aug 6, 2014
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Bijeljina, Bosnia and Herzegovina
    cPanel Access Level:
    Root Administrator
    In Home >> Service Configuration >> Configure PHP and suEXEC

    I have this setting "PHP 5 Handler: dso" and I changed in "PHP 5 Handler: suphp" and now everything is working properly.


    Thank you very much.
     
  9. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,474
    Likes Received:
    202
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Nice. Happy to help when I can. :)
     
Loading...

Share This Page