The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem with VDS-Zend Optimizer

Discussion in 'General Discussion' started by SME, Dec 14, 2013.

  1. SME

    SME Member

    Joined:
    Jan 31, 2009
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Hello,

    after I upgrade Apache in my VDS i see this error in some sites:


    and I try to install ZendOPT in vds with this command: /scripts/phpextensionmgr install Zendopt

    and I receive this error in command line:

    please help me :(

    PHP Version in INFO.php file is: 5.4.22

    Thanks
     
  2. Sys Admin

    Sys Admin Well-Known Member

    Joined:
    Apr 29, 2007
    Messages:
    67
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    Which version of cPanel/WHM you are running? Can you run easyapache again and select Zend Guard during the process?
     
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    653
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    You can see if this extension is installed with a command such as:

    Code:
    php -v
    Are you sure the script you are attempting to access does not need to be encoded for Zend Guard Loader (used for newer versions of PHP) instead of Zend Optimizer?

    Thank you.
     
  4. SME

    SME Member

    Joined:
    Jan 31, 2009
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Hi
    Thanks for your help.
    I upgrade my PHP version to newest version in WHM :)
    Thanks all
     
  5. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    653
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Were you previously using a version of PHP lower than 5.3? With PHP 5.3, Zend Guard Loader has taken the place of Zend Optimizer for running Zend encoded applications.

    Thank you.
     
  6. SME

    SME Member

    Joined:
    Jan 31, 2009
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Yes.
    i use 5.3 but ZO is not active :(
     
  7. quietFinn

    quietFinn Well-Known Member

    Joined:
    Feb 4, 2006
    Messages:
    998
    Likes Received:
    10
    Trophy Points:
    18
    Location:
    Finland
    cPanel Access Level:
    Root Administrator
    There is no Zend Optmizer in PHP5.3.
    In PHP5.2 and earlier it was Zend Optimizer, in PHP5.3 and later it is Zend Guard Loader.
     
Loading...

Share This Page