Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Problema para recompilar Apache con easyApache y YUM

Discussion in 'Discusión en Español' started by eddiemalar, Dec 7, 2010.

  1. eddiemalar

    eddiemalar Member

    Joined:
    Nov 6, 2010
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    51
    Hola, estaba tratando de recompilar apache con un nuevo módulo PHP (zip) y al meomento de recompilar me da un error de YUM... es extraño ya que anteriormente ya habíamos realizado este proceso de forma satisfactoria...

    Este es el error que nos lanza:

    !! The server's system package manager, 'YUM', failed. !!

    !!
    This is the command that failed: yum --exclude=kernel* -y install automake19 gettext libstdc++.x86_64 libpng-devel openssl libpng-dev zlib-devel autoconf261 libidn-devel gmake libidn libXpm openssl-devel automake coreutils patch libltdl3-devel libltdl libopenssl0.9.7-static-devel libtool-ltdl-devel libXpm-devel sed libXpm-dev lsof krb5-dev flex glibc-dev expat-dev krb5-devel libstdc++-devel.x64_64 xorg-x11-devel libtool-ltdl libssl-dev pam-devel libopenssl0-devel zlib1-devel expat-devel libopenssl0-dev expat glibc-devel gcc-c++ zlib bison libjpeg-devel libtool-libltdl-devel libtool openssl-dev libopenssl0 libz-devel libjpeg-dev pam-dev fileutils libltdl-devel libopenssl0.9.7-devel e2fsprogs-devel make libstdc++-dev.x86_64 libX11-devel libstdc++-devel.x86_64 gd cpp xorg-x11-dev gcc ssl-dev autoconf lex !!

    !!
    Since EasyApache was unable to resolve it automatically you should: 1) Manually run the failed YUM command (shown above) via SSH 2) See if your particular error is addressed at EaError < AllDocumentation < TWiki 3) Resolve the YUM problem manually 4) Re-run EasyApache !!

    !! Please visit EaError < AllDocumentation < TWiki for help with this error. !!

    !! Restoring original working apache !!


    Hemos actualizado YUM desde ssh y se efectuó todo satisfactoriamente, no nos dió ningún error... pero en easyApache nos sigue dando problemas...

    Alguna idea..¿?

    Gracias...
     
  2. javiercampos

    javiercampos Well-Known Member
    PartnerNOC

    Joined:
    Jan 12, 2010
    Messages:
    48
    Likes Received:
    0
    Trophy Points:
    56
    Location:
    /tmp
    cPanel Access Level:
    Root Administrator

    Hola,
    Revisaste si el archivo /etc/yum.conf existe alguna linea erronea?
    Por ejemplo existen veces que el archivo al modificarlo quedan lineas sin terminar, te indico un ejemplo del archivo:

    [main]
    exclude=apache* bind-chroot courier* dovecot* exim* httpd* mod_ssl* mysql* nsd* perl* php* proftpd* pure-ftpd* ruby* spamassassin* squirrelmail*
    cachedir=/var/cache/yum
    keepcache=0
    debuglevel=2
    logfile=/var/log/yum.log
    distroverpkg=redhat-release
    tolerant=1
    exactarch=1
    obsoletes=1
    gpgcheck=1
    plugins=1

    # Note: yum-RHN-plugin doesn't honor this.
    metadata_expire=1h

    installonly_limit = 5

    # PUT YOUR REPOS HERE OR IN separate files named file.repo
    # in /etc/yum.repos.d
    assumeyes=1
    failovermethod=priority


    Igualmente te recomendaria aplicar primero un yum clean all y despues un yum update.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. eddiemalar

    eddiemalar Member

    Joined:
    Nov 6, 2010
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    51
    Hola Javier... gracias por contestarme... te pego el contenido de mi archivo /etc/yum.conf

    [main]
    exclude=apache* bind-chroot courier* dovecot* exim* httpd* mod_ssl* mysql* nsd* perl* php* proftpd* pure-ftpd* ruby* spamassassin* squirrelmail*
    cachedir=/var/cache/yum
    keepcache=0
    debuglevel=2
    logfile=/var/log/yum.log
    distroverpkg=redhat-release
    tolerant=1
    exactarch=1
    obsoletes=1
    gpgcheck=1
    plugins=1

    # Note: yum-RHN-plugin doesn't honor this.
    metadata_expire=1h

    installonly_limit = 5

    # PUT YOUR REPOS HERE OR IN separate files named file.repo
    # in /etc/yum.repos.d

    Noté que faltan dos líneas:
    assumeyes=1
    failovermethod=priority

    que las he agregado...

    ya hice un
    yum clean all
    yum update
    yum -y update

    Y nada cambia, seguimos con el mismo error... es extraño porque ya habíamos recompilado easy apache anteriormente y no habíamos tenido problemas... necesitamos instalar la librería PHP ZIP, es urgente...

    Muchas Gracias
     
  4. eddiemalar

    eddiemalar Member

    Joined:
    Nov 6, 2010
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    51
    Otro error que noté cuando hice yum update:

    Transaction Check Error:

    package tzdata-2010i-1.el5.x86_64 (which is newer than tzdata-2010e-1.el5.noarch) is already installed

    file /usr/sbin/sendmail from install of ssmtp-2.61-15.el5.x86_64 conflicts with file from package exim-4.69-23.1_cpanel_maildir.x86_64

    Esto qué es... ¿?¿?¿?¿? no me puede actualizar por problemas de compatibilidad con el exim de cpanel...¿?
     
  5. javiercampos

    javiercampos Well-Known Member
    PartnerNOC

    Joined:
    Jan 12, 2010
    Messages:
    48
    Likes Received:
    0
    Trophy Points:
    56
    Location:
    /tmp
    cPanel Access Level:
    Root Administrator
    Al ejecutar yum update te aparece algun error?
    Podrias indicarme el resultado?

    Igualmente te recomendaria enviar un ticket a cpanel:

    https://tickets.cpanel.net/review/support.cgi
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. eddiemalar

    eddiemalar Member

    Joined:
    Nov 6, 2010
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    51
    el error del yum update es este:

    Transaction Check Error:

    package tzdata-2010i-1.el5.x86_64 (which is newer than tzdata-2010e-1.el5.noarch) is already installed

    file /usr/sbin/sendmail from install of ssmtp-2.61-15.el5.x86_64 conflicts with file from package exim-4.69-23.1_cpanel_maildir.x86_64

    Parece que una versión del ssmtp no es compatible con el exim del cpanel...¿?

    sale ese error y queda allí el update, no continúa a pesar de haber descargado todos los paquetes...

    Gracias
     
  7. javiercampos

    javiercampos Well-Known Member
    PartnerNOC

    Joined:
    Jan 12, 2010
    Messages:
    48
    Likes Received:
    0
    Trophy Points:
    56
    Location:
    /tmp
    cPanel Access Level:
    Root Administrator

    Hola,
    Disculpa la demora.. en tu caso te recomendaria enviar un ticket a cpanel ya que al parecer tendran que desintalar paquetes e instalarlos nuevamente o decirle a tu sysadmin que revise los paquetes mencionados en el error.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. cPanelMarlon

    cPanelMarlon Well-Known Member

    Joined:
    Mar 5, 2010
    Messages:
    101
    Likes Received:
    0
    Trophy Points:
    66
    Location:
    Toronto, Houston
    Buenas,

    Creo que ya abristes el Ticket, necesitas mas ayuda?

    Saludos,
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice