The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problemas con Awstats

Discussion in 'Discusión en Español' started by Piolon, Apr 24, 2011.

  1. Piolon

    Piolon Well-Known Member

    Joined:
    Feb 20, 2007
    Messages:
    48
    Likes Received:
    0
    Trophy Points:
    6
    Como hice ya en otras oportunidades, acabo de instalar un nuevo servidor con CPanel y les pasé algunas cuentas que tenía en otro servidor con la misma versión y configuraciones.

    El problema que tengo es que las estadísticas de Awstats a partir de la fecha dan valores "0", no sé si es porque no procesa los logs o porque directamente los logs no se generan.

    Leí en otros post que revise dominio por dominio en la configuración de Apache, pero me pareció una solución muy compleja. Creo que no debe ser algo muy complicado pero no encuentro solución.

    Agradezco cualquier tipo de ayuda....
    WHM 11.28.87
    CENTOS 5.6 i686 standard

    Saludos cordiales...
     
  2. cPBrianW

    cPBrianW Sysadmin
    Staff Member

    Joined:
    Jan 26, 2011
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Hola Piolon,

    Chequea si los registros de los dominios tienen contenidos en /usr/local/apache/domlogs/. Si los registros contienen datos, puede chequear si su archivo httpd.conf tiene errores de sintaxis con este comando:

    # httpd configtest

    Si todo parece bien en httpd.conf, revisa los valores que tiene en la configuración de los estadísticas. Puede copiar y pegarlas aquí usando los siguientes comandos (estos valores corresponden a WHM: Statistics Software Configuration):

    # cat /var/cpanel/cpanel.config |egrep "skip(aw|web|ana)"
    skipanalog=1
    skipawstats=1
    skipwebalizer=1

    # cat /etc/stats.conf
    ALLOWALL=yes
    DEFAULTGENS=ANALOG,AWSTATS,WEBALIZER
    allow_awstats_include=0

    Si existe la línea "BLACKHOURS", asegurate de que las horas "blackout" dejen tiempo suficiente para que las estadísticas corran.

    Siempre puede abrir un ticket con nosotros usando el siguiente enlace:

    http://go.cpanel.net/supportrequest

    Saludos,
     
  3. Piolon

    Piolon Well-Known Member

    Joined:
    Feb 20, 2007
    Messages:
    48
    Likes Received:
    0
    Trophy Points:
    6
    Muchas gracias por responder... aqui te paso la información que me solicitás...

    root@dns1 [~]# httpd configtest
    [Thu Apr 28 16:28:24 2011] [warn] module security2_module is already loaded, ski pping
    Syntax OK
    root@dns1 [~]# cat /var/cpanel/cpanel.config |egrep "skip(aw|web|ana)"
    skipanalog=1
    skipawstats=0
    skipwebalizer=1
    root@dns1 [~]# cat /etc/stats.conf
    BLACKHOURS=8,9,10,11,12,13,14,15,16,17,18,19,20
    DEFAULTGENS=AWSTATS
    allow_awstats_include=0


    Fijate si encontrás algo raro pero me parece que todo está bien..

    Saludos...
     
  4. cPBrianW

    cPBrianW Sysadmin
    Staff Member

    Joined:
    Jan 26, 2011
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Has revisado los archivos de registro de apache? Verifica que se escriben los datos en /usr/local/apache/domlogs/$domain

    - - -

    Si los registros se llenan ahí, quizás puedes encontrar una pista en /usr/local/cpanel/logs/stats_log. Si awstats corren, verás referencias así:

    [2011-03-22 08:07:13 -0400] About to fork for redacted [DOMAIN: redacted]
    ...
    [2011-03-22 08:07:15 -0400] Create/Update database for config "/home/redacted/tmp/awstats/awstats.redacted.conf" by AWStats version 6.95 (build 1.943)
    [2011-03-22 08:07:15 -0400] From data in log file "/usr/local/apache/redacted/redacted.bkup"...
    [2011-03-22 08:07:15 -0400] Phase 1 : First bypass old records, searching new record...
    [2011-03-22 08:07:15 -0400] Direct access to last remembered record is out of file.
    [2011-03-22 08:07:15 -0400] So searching it from beginning of log file...
    [2011-03-22 08:07:15 -0400] Phase 2 : Now process new records (Flush history on disk after 20000 hosts)...
    [2011-03-22 08:07:15 -0400] Jumped lines in file: 0
    [2011-03-22 08:07:15 -0400] Parsed lines in file: 3
    [2011-03-22 08:07:15 -0400] Found 0 dropped records,
    [2011-03-22 08:07:15 -0400] Found 0 corrupted records,
    [2011-03-22 08:07:15 -0400] Found 0 old records,
    [2011-03-22 08:07:15 -0400] Found 3 new qualified records.

    - - -

    También he visto errores que han aparecido alrededor del 9 Abril debido a la actualización de CentOS de 5.5 a 5.6. Resulta que aparece errores en stats_log que se ven asi>

    -- EXEC MARKER (PID 6101 at 1303217284)--


    Esto se puede arreglar reiniciando cpanellogd:

    # /scripts/restartsrv_cpanellogd


    Si todavía sigue el problema, abre un ticket!

    Saludos,
     
Loading...

Share This Page