The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

probleme whith Ip

Discussion in 'General Discussion' started by mandm.cv, Jan 17, 2013.

  1. mandm.cv

    mandm.cv Registered

    Joined:
    Jan 17, 2013
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hello,
    I have a server with 5 IP address.
    I cpanel / WHM
    I have 5 website on this server.
    I assign to each site an IP address.
    But when I want to do SETTING spf it does not take the ip address of the site but that seveur.
    What should I do to each site on ip and spf dkm
    thank you
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    It's normal for the SPF record to include the primary IP address of the server. This is the IP that Exim is using when you send emails, so that's why it's the IP address used in the SPF record.

    Thank you.
     
  3. krava

    krava Well-Known Member

    Joined:
    Sep 23, 2003
    Messages:
    149
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    As I know Exim uses the dedicated IP address assigned to the account/domain name when the options:

    Send mail from account’s dedicated IP address

    OR

    Reference /etc/mailhelo for outgoing SMTP HELO
    Reference /etc/mailips for outgoing SMTP connections

    are enabled in "Exim configuration manager" of WHM.

    However, it should not cause any problems for you because the default SPF settings contain '+a +mx'. It means the SPF allows to send emails from the IP address of the A and MX record of your domains. In other words once the domain gets a new IP the SPF allows the IP address automatically.
     

Share This Page