The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problems accessing my site from outside of network.

Discussion in 'Bind / DNS / Nameserver Issues' started by Person101, Jul 24, 2016.

  1. Person101

    Person101 Registered

    Joined:
    Jul 23, 2016
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Kansas
    cPanel Access Level:
    Root Administrator
    Don't know if this is correct thread, but I'm having weird issue when I type in my domain name it automatically takes site to https and says that is not configured which is true I do not have https setup for site but when I type http://domain.com it says the server stop responding , I have no problems accessing the cpanel or whm and this only happens out side the network. If I'm inside the network where server is and type the domain name it works fine , I can ping the website and it is pulling correct ip for the life of me I can not what is going on. Any help would be appreciated. This is a fresh cpanel copy on centos 7
     
  2. 24x7server

    24x7server Well-Known Member

    Joined:
    Apr 17, 2013
    Messages:
    1,146
    Likes Received:
    34
    Trophy Points:
    48
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Hello :),

    It's seems that there is an issues with the DNS. Have you correctly setup nameserver for your domain ? Please check that and update correct nameserver for your domain so that your domain will work.
     
  3. Person101

    Person101 Registered

    Joined:
    Jul 23, 2016
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Kansas
    cPanel Access Level:
    Root Administrator
    Domain servers are correct and they are pulling correct ip , Like I said I can site using domain name in the local network and the domain is using the servers ip address not a local so it is definitely working, plus on outside networks i can use domain.com:2082 and 2086 to access the cpanel and whm and it works fine so dns seems to be fine
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello,

    Do you have any custom entries in the .htaccess file within the account's home directory, or within the public_html directory? Have you tested with a HTML test page to verify the redirect doesn't come from your application's configuration file?

    Thank you.
     
  5. Person101

    Person101 Registered

    Joined:
    Jul 23, 2016
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Kansas
    cPanel Access Level:
    Root Administrator
    There is no custom .htaccess this is fresh install and fresh os , also I did install joomla to make sure that it wasn't because the site was blank , the weird thing is I can the site fine from local network but not from outside , but can access cpanel and whm fine outside so seems the dns is working , I am behind nat, I have all ports set to forward I did set server as the dmz , I have made sure there is no firewall on os and still unable to access the site from outside the network.
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Check to ensure 1:1 NAT is enabled if you are using a NAT environment by running the following command:

    Code:
    /scripts/build_cpna
    This is documented at:

    1:1 NAT - Documentation - cPanel Documentation

    Thank you.
     
Loading...

Share This Page