The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problems creating and terminating accounts with WHM

Discussion in 'General Discussion' started by starterwebsites, Jun 6, 2007.

  1. starterwebsites

    starterwebsites Registered

    Joined:
    Jan 9, 2006
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Today I started having problems terminating an account through account functions, when I choose an account then click terminate account after clicking the terminate button I get forwarded to a blank page and account does not get terminated.

    When I try and create a new account the only msg I see after I click create is

    Account created, but their are no details and the account does not get created.

    Any help would be appreciated.
     
  2. jrehmer

    jrehmer Well-Known Member

    Joined:
    Apr 10, 2003
    Messages:
    287
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Denver, CO
    Do you see anything in /usr/local/cpanel/logs/error_log after terminating an account?
     
  3. RandallSquared

    RandallSquared Registered

    Joined:
    Sep 22, 2006
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    I'm not starterwebsites, but I'm having this same problem for the first time today, and my error_log has:

    Can't locate Whostmgr/Accounts/Create.pm in @INC (@INC contains: /usr/local/cpanel /scripts /usr/lib/perl5/5.8.7/i686-linux /usr/lib/perl5/5.8.7 /usr/lib/perl5/site_perl/5.8.7/i686-linux /usr/lib/perl5/site_perl/5.8.7 /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl/5.8.4 /usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl/5.8.2 /usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl .) at /scripts/wwwacct line 10.
    BEGIN failed--compilation aborted at /scripts/wwwacct line 10.

    in it.
     
  4. lizardo

    lizardo Member
    PartnerNOC

    Joined:
    Sep 27, 2005
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Arequipa - Peru
    I have the same problem and the same error,

    Plase what is the problem
     
  5. starterwebsites

    starterwebsites Registered

    Joined:
    Jan 9, 2006
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Problem resolved but...........

    problem was resolved by initiating a Cpanel update. Except now can't login to any FTP accounts getting 530 Login authentication failed even after I change the password and it is the same for every account on the server, yet I am able to use the file manager through cpanel, everything else seems to be working fine.
     
  6. RandallSquared

    RandallSquared Registered

    Joined:
    Sep 22, 2006
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Yeah, it looks like everyone's having problems with updates recently, so I'm hoping to avoid those problems, if only we can get an answer for why this is happening. Not being able to create accounts is far less of a problem than having FTP stop working, in my opinion!
     
  7. lizardo

    lizardo Member
    PartnerNOC

    Joined:
    Sep 27, 2005
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Arequipa - Peru
    Do you update to Cpanel 11 ?
     
  8. starterwebsites

    starterwebsites Registered

    Joined:
    Jan 9, 2006
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    ok found solution to hopefully the last problem, FTP login problem solution,
    It seems that they changed the login username format after the update the username format is username@domain.com
    if you want to reset it as it was before just username go into ftp configuration switch between modes (pureftp, pro) then switch back to the mode you were using and login is now just username

    How can Cpanel not advise their customers of drastic changes?
     
  9. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    It looks like it failed to download some files during the update.

    /scripts/upcp --force

    should solve the problem
     
  10. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    I've seen a few reports of this, but we have never been able to recreate the problem. I'll get it added to the release notes, until we can nail down the cause.
     
  11. Zazoos1

    Zazoos1 Well-Known Member

    Joined:
    Jan 1, 2004
    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    6
    I, too, cannot create new accounts today. Will running
    /scripts/upcp --force
    break anything on my server , or is it completely safe to use?

    Thanks for your time!
     
  12. RandallSquared

    RandallSquared Registered

    Joined:
    Sep 22, 2006
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Well, I just did that, and noticed from messages flying by that this moves you straight to 11. :( In my case, that seems to have worked out okay so far -- I haven't run across anything that's broken since the upgrade, so perhaps I got lucky.
     
  13. lizardo

    lizardo Member
    PartnerNOC

    Joined:
    Sep 27, 2005
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Arequipa - Peru
    i run upcp and all works fine now.
     
  14. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
  15. GordonH

    GordonH Well-Known Member

    Joined:
    Sep 6, 2001
    Messages:
    104
    Likes Received:
    0
    Trophy Points:
    16
    Nick,

    Can you confirm that Cpanel should just use "username" as the username for FTP or has it officially been changed to "username@domain" ?

    What is it supposed to do?

    This would be a major change and we would need to tell a lot of people.
     
  16. Zazoos1

    Zazoos1 Well-Known Member

    Joined:
    Jan 1, 2004
    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    6
    Thanks, all. I went ahead and ran it too and so far all seems well. I appreciate your help!
     
  17. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    username should work for dedicated ips
    username@domain.com should work for dedicated and shared ips.


    Just save yourself some trouble and use username@domain.com for everything.
     
  18. bapline

    bapline Member

    Joined:
    Nov 16, 2006
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    All is not well for us ... 2 boxes with BIG problems ... we ran the update script again and it worked for 1 new account creation... almost... now doesn't work again.... :eek:

    We need to rollback this update immediately... how do we do this ...
     
  19. GordonH

    GordonH Well-Known Member

    Joined:
    Sep 6, 2001
    Messages:
    104
    Likes Received:
    0
    Trophy Points:
    16

    Thats a biot difficult with 37,000 live domains on the system.
    I would need to contact all the users.
     
  20. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    Just switch from pro to pure and back again pro to whatever you were on. That will force a rebuild of /etc/proftpd.conf


    If you are having the problem with pure-ftpd then please open a ticket as there isn't a known issue there.
     
Loading...

Share This Page