The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problems Creating subdomains

Discussion in 'General Discussion' started by eddiemalar, Nov 13, 2010.

  1. eddiemalar

    eddiemalar Member

    Joined:
    Nov 6, 2010
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    I have problems trying to create new subdomains, the process is carried out correctly, create the folder for the subdomain and I get the confirmation of the creation. I can access the subdomain via the URL to the folder (eg http://dominio.com/subdominio), but I can not access it via the url that should be generated for the same (eg http://subdominio . dominio.com) :mad:

    the same happens when I add new domains to WHM, until I restart the named, domains are not found, even though they are generated DNS zones properly.

    ... someone knows where is the problem, I have my own server and access to WHM ...

    Thanks a lot for your help :)
     
    #1 eddiemalar, Nov 13, 2010
    Last edited: Nov 13, 2010
  2. GaryT

    GaryT Well-Known Member

    Joined:
    May 19, 2010
    Messages:
    321
    Likes Received:
    3
    Trophy Points:
    16
    This could be a problem on your end, Maybe some of your DNS has not updated, The first thing you should do is try accessing it via proxy to make sure its changed before fiddling with settings.

    Try restarting the DNS server via WHM > Restart Services > DNS

    But to me it does seem like the issue is with your connection and not the server.
     
  3. eddiemalar

    eddiemalar Member

    Joined:
    Nov 6, 2010
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    GaryT... When I restart the DNS server from WHM, subdomains begin to resolve correctly and can access them without problems. But this is a BIG problem, I have several clients and I can not constantly be aware of if they create a new subdomain or not to restart the dns for the new areas work correctly ....

    I need a resolution to this problem, I tried a forced update of cpanel / whm and the conflict remains unchanged, previously functioned well and had no problems, but a little over a month since I encounter this problem and it seems NOT resolved.

    Thank you very much for attending my post.
     
  4. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Please open a ticket so we can see what is happening here. The only idea I have right now for it would be that someone has set in Tweak Settings > "BIND deferred restart time" a time interval and so bind isn't restarting automatically. If that isn't the case, then you might want to tail the logs when creating an addon or subdomain to see if there are any errors for cPanel:

    Code:
    tail -f /usr/local/cpanel/logs/error_log
    Also, enable verbose logging in Tweak settings:

    Code:
    Log dnsadmin requests
    At that point, you can again create an addon or subdomain and then check this log:

    Code:
    tail -f /usr/local/cpanel/logs/dnsadmin.log
    Finally, you may also want to check both /var/log/messages for the DNS logs and /var/named/data/named.run (if that even exists on your machine).

    Again, though, it's probably best to just open a ticket. You can do that either using the link in my signature or using WHM > Support Center > Contact cPanel
     
  5. eddiemalar

    eddiemalar Member

    Joined:
    Nov 6, 2010
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Excellent support ... thank you very much ... was indeed a problem of deferred restart BIND configuration time, we had activated a certain time understanding that if we did not BIND never be resumed.

    Problem solved, thank you very much for your help
     
Loading...

Share This Page