The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problems in sending emails on port 587

Discussion in 'E-mail Discussions' started by Gabrielle, Feb 10, 2011.

  1. Gabrielle

    Gabrielle Member

    Joined:
    Nov 10, 2002
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    One of my clients has to send out emails on port 587. On the server we are using the the ConfigServer Firewall, Mailscanner and Exim and to open port 587 I followed the instructions on the ConfigServer Forum, i.e.:
    1.) I included daemon_smtp_ports = 25 : 587 in the 1st text box of the the Advanced Exim Editor
    2.) I checked that port 587 is included in the allowed TCP_OUT and TCP6_OUT ports in the csf firewall

    I then send a test email from my PC (Thunderbird) using port 587 and no authentication and it was perfectly working. However, it is still not working for my clients.

    Also when doing a port scan, it says that port 587 is closed, but perhaps this is due to the csf firewall, which does not like port scanning.

    Any suggestions regarding this problem are very much appreciated!
    Thank you Gabrielle
     
  2. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Hello Gabrielle,

    To determine if the issue is the firewall, could you disable the firewall to test if these users are then able to successfully send out?

    Also, it's possible these other users aren't changing their outgoing port to 587 and kept it as 25. If they did, that might explain why it isn't working for them if their ISP blocks that port.

    Thanks.
     
  3. Gabrielle

    Gabrielle Member

    Joined:
    Nov 10, 2002
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Hello and thanks for your fast reply!

    We did the test, but the user is still not able to send a message.

    We already did verify this and their outgoing port is set to 587.

    Thank you Gabrielle
     
  4. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Hello Gabrielle,

    Have you asked this user if they have a firewall on their own system that is blocking ports? Many people using Windows have the Windows Firewall or another firewall enabled. That firewall typically blocks non-needed ports.

    Thanks.
     
  5. Gabrielle

    Gabrielle Member

    Joined:
    Nov 10, 2002
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Thank you for this advice! Opening their office firewall for this port seems to have solved the problem. We will now check the other places these clients connect from.
    Again thanks for your precious help. Gabrielle
     
Loading...

Share This Page