The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problems on FreeBSD WHM 8.5.1 cPanel 8.5.3-S6

Discussion in 'General Discussion' started by Sonny, Oct 22, 2003.

  1. Sonny

    Sonny Member

    Joined:
    Aug 15, 2003
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Missouri
    I'm running FreeBSD and have found a few things just aren't working on my system:

    1.) WHM -> Email -> Manage Mail Queue

    2.) WHM -> Email -> View Relayers

    3.) WHM -> Account Functions -> Upgrade/Downgrade an Account

    I'm also having a weird problem if I add a new package then assign that to a domain via the upgrade/downgrade an account when you go to List Accounts you will see that the domain doesn't have any of the info in it from the package and where the package is listed you will see a square box next to the package name..

    Anyone else having these troubles on FreeBSD ;(
     
  2. jdawes

    jdawes Well-Known Member

    Joined:
    Aug 7, 2003
    Messages:
    59
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Australia
    i have freebsd running and havent noticed those problems. I ran the update that came up in red in WHM a few days back.

    Still waiting for my postgres but im sure cpanel devs will help me when they have time.
     
  3. Sonny

    Sonny Member

    Joined:
    Aug 15, 2003
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Missouri
    I rebooted and that fixed whatever was effecting my upgrade/downgrade account..

    I still have the email issues of not being able to view relayers or manage mail queue..
     
  4. cass

    cass Well-Known Member

    Joined:
    Jul 17, 2002
    Messages:
    354
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Argentina/USA/Mexico
    Same here too...

    anyone submited a ticket or so?
    if not... do it! :)

    Dunno but I think FreeBSD runs an older version of Exim than RedHat ... need to check if was updated or not.
     
  5. Sonny

    Sonny Member

    Joined:
    Aug 15, 2003
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Missouri
    I opened a couple tickets on my issues. Just been asked for password to system but never heard back on the exim issues.

    My exim says it's 4.24 which is the latest out.. I think the problem has to do with differences between where red splat see's it's configuration files and where FreeBSD stores it's files.. BUT w/o being able to see the scripts because they are being called from /scripts2 it's hard to even try to diagnose the issues...

    :eek:

    ---
    Sonny
     
  6. Sonny

    Sonny Member

    Joined:
    Aug 15, 2003
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Missouri
    :cool:

    Trouble ticket helped!

    Darren M sent me this message in reply to one of the Exim problems.. It should help other FreeBSD users till the developers can get the check / fix in place..

    Hello,


    I ktrace'd whm and saw it was looking in /usr/sbin/ for exim, while on bsd it's /usr/local/sbin/exim . I created a symbolic link and it seems to work fine:


    ln -s /usr/local/sbin/exim /usr/sbin/exim


    I'm still sending this to the developers since they'll probably need to add a check for it in the default location.


    Thanks,
    Darren
    --
    cPanel, Inc.


    This still leaves the View Relayers that is borked but we are getting closer...
     
    #6 Sonny, Oct 22, 2003
    Last edited: Oct 23, 2003
Loading...

Share This Page