The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problems rebuilding Apache

Discussion in 'EasyApache' started by bert, Jul 16, 2002.

  1. bert

    bert Well-Known Member

    Joined:
    Aug 21, 2001
    Messages:
    602
    Likes Received:
    0
    Trophy Points:
    16
    Every time I try to recompile Apache on a particular server with buildapache.sea I get the following error:

    checking for init_mcrypt in -lmcrypt... no
    configure: error: Sorry, I was not able to diagnose which libmcrypt version you have installed.
    make: *** No targets specified and no makefile found. Stop.
    make: *** No rule to make target `install'. Stop.


    I cannot get it to install unless I remove the libmcrypt option. This is really driving me nuts now.

    Any thoughts?
     
  2. hostbet

    hostbet Well-Known Member

    Joined:
    Aug 13, 2001
    Messages:
    80
    Likes Received:
    0
    Trophy Points:
    6
    I have the same problem....

    Please advise! :(
     
  3. bdraco

    bdraco Guest

    Disable mcrypt support by using the advanced option.
     
  4. hostbet

    hostbet Well-Known Member

    Joined:
    Aug 13, 2001
    Messages:
    80
    Likes Received:
    0
    Trophy Points:
    6
    O.k what I do is edit the buildscript and take the following out:
    --with-mcrypt --with-ming=../ming-0.1.1 on two lines.

    it works after that!

    even I make the install with not mcrypt support it will give another arror for ming.

    Hope that helps solve the problem....

    It took me 6 hours of hard work and searching in the forum for clues to figure this out and the server down for that time :(
     
  5. abandoned User

    Joined:
    Sep 16, 2002
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    DO NOT take out --with-ming=../ming-0.1.1, --with-ming=../ming-0.1.1 adds some VERY useful functionality
     
  6. hostbet

    hostbet Well-Known Member

    Joined:
    Aug 13, 2001
    Messages:
    80
    Likes Received:
    0
    Trophy Points:
    6
    What should I do?
    It will get error even I desable the mcrypt support from the installation.

    I had to bring the server up before the users kill me a live .....

    (they were getting the stove ready)
     
  7. hostbet

    hostbet Well-Known Member

    Joined:
    Aug 13, 2001
    Messages:
    80
    Likes Received:
    0
    Trophy Points:
    6
    also I have problem with Netscape after the update... it will not show the site contents, just the source (novice )
     
  8. bert

    bert Well-Known Member

    Joined:
    Aug 21, 2001
    Messages:
    602
    Likes Received:
    0
    Trophy Points:
    16
    We had to disable mcrypt and ming, both. Otherwise apache will not compile.
     
  9. moronhead

    moronhead Well-Known Member

    Joined:
    Aug 12, 2001
    Messages:
    706
    Likes Received:
    0
    Trophy Points:
    16
    I thought ming required version 0.2 in PHP4. That may be one of the reasons.
     
  10. bert

    bert Well-Known Member

    Joined:
    Aug 21, 2001
    Messages:
    602
    Likes Received:
    0
    Trophy Points:
    16
    Actually, we starting having this problem after one of our techs recompiled php manually. In essence, after that compile, we could no longer use buildapache.sea. The worst part is that there is absolutely nothing that we can do to fix it other than reinstall Redhat from scratch.
     
  11. Juanra

    Juanra Well-Known Member

    Joined:
    Sep 22, 2001
    Messages:
    777
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Spain
    It happened something similar to me after trying to recompile PHP with pdflib. I didn't RTFM before installing pdflib (I copied the pdflib files into PHP's ext directory but didn't run ./buildconf). Solution for me was RTFM, recompiling PHP and then Apache went fine.

    What I don't understand very well is that you can't rerun buildapache.sea.
     
  12. moronhead

    moronhead Well-Known Member

    Joined:
    Aug 12, 2001
    Messages:
    706
    Likes Received:
    0
    Trophy Points:
    16
    [quote:e338595312][i:e338595312]Originally posted by bert[/i:e338595312]

    Actually, we starting having this problem after one of our techs recompiled php manually. In essence, after that compile, we could no longer use buildapache.sea. The worst part is that there is absolutely nothing that we can do to fix it other than reinstall Redhat from scratch.[/quote:e338595312]
    If you are compiling php manually then you don't really need to enable php in buildapache. These two don't get on very well together!

    & ... but didn't run ./buildconf

    That's true. ./buildconf helps a lot in finding out the missing libraries etc that php needs.
     
  13. bert

    bert Well-Known Member

    Joined:
    Aug 21, 2001
    Messages:
    602
    Likes Received:
    0
    Trophy Points:
    16
    I can run buildapache.sea, but it will give me a stop error saying that it cannot determine the libraries for mcrypt or something like that, so if I disable mcrypt, it will then give me the same error with ming. I can disable mcrypt and ming and compile apache with buildapache.sea without problems.

    mcrypt is not so important, but ming is somewhat important to some users. I just learned my lesson, I will never ever again recompile apache or php manually on a cpanel box, I will always use and will always stick to buildapache.sea :p

    The only reason why we wanted to compile php manually was because we wanted to upgrade gd to 2.0.x
     
  14. moronhead

    moronhead Well-Known Member

    Joined:
    Aug 12, 2001
    Messages:
    706
    Likes Received:
    0
    Trophy Points:
    16
    There's nothing wrong with compiling php manually and let buildapache handle the rest. Simply disable the php option entirely in advanced mode. That way you can quickly upgrade to a newer version of php when you want to or when you need to have a new feature that's not yet in buildapache's php such as gd 2.0.

    As Juanra mentioned, running ./buildconf in the php source directory will give you all the info you need about the missing or outdated libraries in your system. You can install them one by one untill ./buildconf gives no more error messages.
     
  15. hostbet

    hostbet Well-Known Member

    Joined:
    Aug 13, 2001
    Messages:
    80
    Likes Received:
    0
    Trophy Points:
    6
    [quote:0b9851a119][i:0b9851a119]Originally posted by bert[/i:0b9851a119]

    I can run buildapache.sea, but it will give me a stop error saying that it cannot determine the libraries for mcrypt or something like that, so if I disable mcrypt, it will then give me the same error with ming. I can disable mcrypt and ming and compile apache with buildapache.sea without problems.

    mcrypt is not so important, but ming is somewhat important to some users. I just learned my lesson, I will never ever again recompile apache or php manually on a cpanel box, I will always use and will always stick to buildapache.sea :p

    The only reason why we wanted to compile php manually was because we wanted to upgrade gd to 2.0.x[/quote:0b9851a119]

    I have the same problem.....

    Some time I feel I'm runing Cpanel BETA or something like that since everytime I use that file it will give me a big problem.
     
  16. bert

    bert Well-Known Member

    Joined:
    Aug 21, 2001
    Messages:
    602
    Likes Received:
    0
    Trophy Points:
    16
    [quote:2fcd010917][i:2fcd010917]Originally posted by moronhead[/i:2fcd010917]

    There's nothing wrong with compiling php manually and let buildapache handle the rest. Simply disable the php option entirely in advanced mode. That way you can quickly upgrade to a newer version of php when you want to or when you need to have a new feature that's not yet in buildapache's php such as gd 2.0.

    As Juanra mentioned, running ./buildconf in the php source directory will give you all the info you need about the missing or outdated libraries in your system. You can install them one by one untill ./buildconf gives no more error messages.
    [/quote:2fcd010917]

    Well, I just wanted to make my life easier and compile php with buildapache.sea, that's all, but I guess I won't be able to do that with that particular server any more.

    Thanks moronhead for the heads up :)
     
  17. Curious Too

    Curious Too Well-Known Member

    Joined:
    Aug 31, 2001
    Messages:
    427
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    I installed CPanel on a new server yesterday (Redhat 7.3) and ran into problems compiling PHP with mcrypt and ming. What I learned:

    1. The gd-2.0.4.tar.gz, ming-0.2a.tgz and libmcrypt-2.5.3.tar.gz files were placed in the buildapache folder but were not unzipped and installed during the CPanel installation. I manually unzipped and installed this software.

    2. When running &make test& for gd-2.0.4 I encountered errors. I changed this line in the Makefile:

    LIBDIRS=-L/usr/lib/X11 -L/usr/X11R6/lib -L/usr/local/lib

    to this:

    LIBDIRS=-L/usr/lib/X11 -L/usr/X11R6/lib -L/usr/lib

    and re-ran &make test& without encountering errors.

    I then ran &./config.nice&, &make& and &make install& in the PHP-4.2.3 directory and did not encounter any errors. PHP was successfully installed with these options:

    ./configure' '--with-apxs=/usr/local/apache/bin/apxs' '--with-xml' '--enable-bcmath' '--enable-calendar' '--with-curl' '--enable-ftp' '--with-gd-dir=../gd-2.0.4' '--with-jpeg-dir=/usr/local' '--with-png-dir=/usr' '--with-imap' '--with-imap-ssl' '--with-ming-dir=../ming-0.2a' '--enable-magic-quotes' '--with-mysql' '--with-pear' '--enable-safe-mode' '--enable-track-vars' '--with-ttf' '--enable-versioning' '--with-zlib' '--with-kerberos' '--with-mcrypt'
     
  18. ozzi4648

    ozzi4648 Guest

    [quote:723fb70a50][i:723fb70a50]Originally posted by bert[/i:723fb70a50]

    Every time I try to recompile Apache on a particular server with buildapache.sea I get the following error:

    checking for init_mcrypt in -lmcrypt... no
    configure: error: Sorry, I was not able to diagnose which libmcrypt version you have installed.
    make: *** No targets specified and no makefile found. Stop.
    make: *** No rule to make target `install'. Stop.


    I cannot get it to install unless I remove the libmcrypt option. This is really driving me nuts now.

    Any thoughts?[/quote:723fb70a50]

    This BUILDAPACHE.SEA is a bit flakey and alot of libraries i needed were not untarred during the build.

    Do this.

    Find the buildapache/ directory, the one used to recompile the entire system, cd into it. Look around there should be a file called
    libmcrypt-2.5.3.tar.gz, depending on which which build you have libmcrypt may be a different version then the one im showing you. Now, look for the untarred libmcrypt directory. Is there one? Probably not. Try untarring libmcrypt-2.5.3.tar.gz. Look for any other modules you need installed. For eg i found that mod_perl-1.27.tar.gz was not untarred after my build finished. Why is that? So i untarred it and ran buildapache.sea again and now i have mod_perl 1.27 installed instead of mod_perl 1.26

    Ok so now that you untarred it try doing the buildapache rebuild again. This time it should be included as part of your system build.
    During the build, select the 2 Advanced option and select all the modules you want to include in your build, including the ones for php.

    My php config looks like this:

    './configure' '--with-apxs=/usr/local/apache/bin/apxs' '--with-xml' '--enable-bcmath' '--enable-calendar' '--with-curl' '--with-swf=/usr/local/flash' '--enable-ftp' '--with-gd=../gd-2.0.4' '--with-jpeg-dir=/usr/local' '--with-png-dir=/usr' '--with-xpm-dir=/usr/X11R6' '--with-imap=../imap-2001.BETA.SNAP-0105220031' '--with-imap-ssl' '--with-kerberos' '--with-mcrypt' '--with-ming=../ming-0.2a' '--enable-magic-quotes' '--with-mysql=/usr' '--with-pgsql=/usr' '--with-pear' '--enable-xslt' '--with-xslt-sablot' '--enable-safe-mode' '--enable-sockets' '--enable-track-vars' '--with-freetype-dir=/usr' '--enable-gd-native-ttf' '--enable-versioning' '--with-zlib'
     
Loading...

Share This Page