The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problems sending mail.......

Discussion in 'E-mail Discussions' started by Xiode, Nov 27, 2006.

  1. Xiode

    Xiode Well-Known Member

    Joined:
    Oct 14, 2005
    Messages:
    73
    Likes Received:
    0
    Trophy Points:
    6
    Here lately I have been having some issues sending mail... All my registration email on my site are getting kicked back... but the PM notifications will go through... Is there anyway to reset Exim... It started when I noticed that mailscanner stopped working. Now I can't even get it to work.


    ex in " Mail delivery failed: returning message to sender "
    name@hotmail.com
    unrouteable mail domain "hotmail.com"

    webmaster@domain.com
    unrouteable mail domain "domain.com"

    name@gmail.com
    unrouteable mail domain "gmail.com"
     
  2. deanstev

    deanstev Well-Known Member

    Joined:
    Jun 10, 2004
    Messages:
    110
    Likes Received:
    0
    Trophy Points:
    0
    check your resolver conf ip's
     
  3. jamesmarks

    jamesmarks Registered

    Joined:
    Dec 5, 2006
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    I'm getting the same problem.

    It seems to have something to do with the Return-path header.

    When I send mail a return path <username>@<serverurl> is added to my email (not email@domain.com).

    I looked high and low in WHM and can't find an option to to stop WHM from automatically adding this Return-path header to my outgoing mail() requests.

    Searching the forums, but if anyone has a suggestion in the meantime, it would be appreciated...
     
  4. rkgroups

    rkgroups Member

    Joined:
    Nov 12, 2006
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    using outlook??

    I had same problem when I was using Outlook. I was able to send emails to same domain name but not to other domain names.

    For short time, I used www.mail2web.com
    check it there whether you can send your emails or not.

    and yes, try to configure outlook by cpanel . may be that will work. and also in outlook in your email account settings check for advance setting and in outgoing mail server setting , try to tweak it to setting like incoming server. just tweak your outlook setting and you will get clear idea.
     
  5. jamesmarks

    jamesmarks Registered

    Joined:
    Dec 5, 2006
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    That may work for outlook, but this is a server side script that relies on automation.

    The goal is to avoid doing any manual work as this could generate anywhere between 1 and 10,000 emails per day depending on interest and response.

    Beyond the fact that most of us don't like doing more work than we have to, sending as many as several thousand emails by hand in a day is also a very difficult task to accomplish. ;)

    I updated PHP to version 5.2 and added "-femail@domain.com" to the sendmail parameters, but this didn't seem to be enough.

    I also wanted to have the capability to capture and forward the IP of the person using the script just as if they were using their email client.

    I had to change my directions and write a wrapper for some functionality available in a script someone else wrote. It isn't perfect, but I seem to have a system that is beginning to work using xpertmailer (www.xpertmailer.com) and various header tweaks.

    Does anyone know what headers identify a person's IP address to an autoresponder?

    Regards,

    James
     
  6. Xiode

    Xiode Well-Known Member

    Joined:
    Oct 14, 2005
    Messages:
    73
    Likes Received:
    0
    Trophy Points:
    6
    unchecked these two options.... now it works....


    Server Configuration >> Tweak Settings >> Track the origin of messages sent though the mail server by adding the X-Source headers (exim 4.34+ required)

    Server Configuration >> Tweak Settings >> Prevent the user "nobody" from sending out mail to remote addresses (PHP and CGI scripts generally run as nobody if you are not using PHPSuexec and Suexec respectively.)
     
  7. chilihost

    chilihost Well-Known Member

    Joined:
    Mar 1, 2005
    Messages:
    72
    Likes Received:
    0
    Trophy Points:
    6
    i had the same problem and removed this:
    Server Configuration >> Tweak Settings >> Track the origin of messages sent though the mail server by adding the X-Source headers (exim 4.34+ required)

    and it worked fine.
     
Loading...

Share This Page