The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problems Using Nginxcp with SSL-enabled vhosts

Discussion in 'General Discussion' started by mcpacific, May 9, 2016.

  1. mcpacific

    mcpacific Member

    Joined:
    May 3, 2015
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Los Angeles, CA
    cPanel Access Level:
    Root Administrator
    I have been trying to get some CMS sites to use Nginx with SSL connections, but keep getting redirect loops and/or mixed content warnings.

    Inside the server block of the default vhost domain configuration, I added:

    listen XXX.XXX.XXX.XXX:443 http2 ssl;
    ssl_certificate /PATH/certs/bundle.crt;
    ssl_certificate_key /PATH/keys/bundle.key;

    Regular HTML works just fine with an https connection, but when accessing WordPress (or Magento for a different user), it seems to be problematic and doesn't work.

    Anyone have any insight or suggestions? I've posted on the nginxcp forum but no reply there yet.
     
    #1 mcpacific, May 9, 2016
    Last edited: May 9, 2016
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,674
    Likes Received:
    646
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello,

    I suggest consulting with the developer of the Nginx plugin you are using to determine how to best add that custom entry. Or, try disabling Nginx temporarily to see if you can reproduce the issue with the standard Apache installation.

    Thank you.
     
Loading...

Share This Page