Problems while creating email addresses

SEATi

Member
Jun 28, 2004
9
0
151
Hi,

I just set up cpanel/whm on a couple of servers, but when I try to create a new email account I get a message indicating that I need to specify a password, and the login/password/domain don't show up in the results page, even when I filled out every field.

The full message is:

Mail Account Maintenance



Account Created

The e-mail account @ with the login
You must specify a password. Ignore any messages of success this can only result in failure! and password with a quota of megs was successfully created.

I didn't erase the info, it just doesn't show up.

Thanks in advance for your replies. :)
 

webignition

Well-Known Member
Jan 22, 2005
1,876
0
166
Try updating to the latest RELEASE first and then try again, just incase the freshly installed version of WHM/Cpanel is not the latest. This is assuming that your fresh install is the latest STABLE (which is often the case).

WHM > Server Setup > Update Config:

Code:
[B]cPanel/WHM Updates[/B]
[ ] Automatic (STABLE tree)
[ ] Automatic (RELEASE tree)
[ ] Automatic (CURRENT tree)
[ ] Manual Updates Only (STABLE tree)
[B][X] Manual Updates Only (RELEASE tree)[/B]
[ ] Manual Updates Only (CURRENT tree)
[ ] Manual Updates Only (bleeding EDGE tree)
[ ] Never Update
Then from SSH:

/scripts/updatenow
/scripts/upcp
 

SEATi

Member
Jun 28, 2004
9
0
151
No luck yet

It's still displaying the same error message, it's as if the information wasn't being posted (desired username, desired password, desired quota). However I've already checked every php.ini and register_globals is enabled and the register order is the right one "EGPCS".

If this helps, I'm using FreeBSD 4.8-RELEASE, I know it's not the latest but it's kinda hard to upgrade right now.