Problems with adding functionality to Vertex theme

timothee

Member
May 25, 2003
6
0
151
Hi all,

I know the Vertex theme isn't supported officially, but I have a question about it though :)

Because of a couple of missing features in the vertex theme compared to for example the (official) Xskin theme, I'm trying to edit the Vertex theme so all needed features are working.
Some features which I edited/added do already work, but some do not and my question is "why do they not work??"!

Has anyone any clue why the following things don't work??

- I copied the "systeminfo" blocks of the Xskin theme and integrated them in the left "info bar" of the Vertex theme. I compared both sources and everything seems to be equal, but most of the information isn't displayed at the Vertex theme (for example the Operating System...)!!
The used cpanel code (<cpanel something="something()"> is, as I suppose, the same for every theme, isn't it? So, why does the uptime show up and does the OS information not?!?!

- I added the possibility to choose your (add-on)domain in the /subdomain/index.html as it appeared in the Xskin theme. The pull-down menu is shown, but it does not create the appropriate subdomain! When I choose to create a subdomain forum for one of my add-on domains, it says it cannot create it because it already exists!? When I try to create a subdomain test for the same add-on domain, it says it created the subdomain succesfully, but when I look at the "existing subdomains" I see that it actually created the test subdomain for my primary domain instead of the choosen add-on domain (that explains why it could not create the forum subdomain because that one existst already for the primary domain!)!!
How is this possible? Again...I copied the Xskin code, so IMHO it should work, isn't it?

Has anyone any idea why the same code does nog work (at least not always) in another theme??

TIA for the help and insights :)

Timothée Bastin


Edit: Hmm...seems that the Xskin theme also has this problems with adding a subdomain for a specific add-on domain :confused:
The Blue Lagoon theme has nog problems with this.
 
Last edited:

Website Rob

Well-Known Member
Mar 23, 2002
1,502
1
318
Alberta, Canada
cPanel Access Level
Root Administrator
I think the lack of response is due to lack of interest in the Vertex theme. My only suggestion is to also compare with other themes included with Cpanel and see if they might help.

cPanel.net Support Ticket Number: