Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Problems with AutoSSL Renewal

Discussion in 'Security' started by subby01, Dec 27, 2018.

  1. subby01

    subby01 Member

    Joined:
    Dec 27, 2018
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Sydney
    cPanel Access Level:
    Website Owner
    Hi,

    I am having an issue with the AutoSSL certificate not renewing. It has been unable to renew for weeks. I have contacted my Webhost and ensured that AutoSSL is enabled, I have tried deleting all previous certificates and running it again, but I am still not getting anywhere.

    My Webhost is telling me to wait until it resolves, but I know it should not take this long. Previous renewals were seamless, no problems at all.

    Please Help!
     
  2. subby01

    subby01 Member

    Joined:
    Dec 27, 2018
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Sydney
    cPanel Access Level:
    Website Owner
    The provider “cPanel (powered by Comodo)”’s AutoSSL queue already contains a certificate request. The request’s start time is Dec 17, 2018, 3:14:06 AM UTC, and its last poll time is Dec 17, 2018, 3:14:10 AM UTC.

    The post above seems to be the issue, but that request was 11 days ago?
     
    #2 subby01, Dec 27, 2018
    Last edited by a moderator: Dec 28, 2018
  3. cPanelLauren

    cPanelLauren Forums Analyst II Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    5,715
    Likes Received:
    436
    Trophy Points:
    233
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi @subby01

    Typically in this case there's an issue with the certificate being issued by Sectigo. Can you run the following and let us know the output?

    Code:
    /usr/local/cpanel/bin/autossl_check_cpstore_queue --force
    Also if you look at the SSL pending queue can you grab the Order Item ID and I can look it up internally for you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. subby01

    subby01 Member

    Joined:
    Dec 27, 2018
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Sydney
    cPanel Access Level:
    Website Owner
    Hi,

    Thanks for the reply,

    - The code you supplied cleared all the pending queue? Was that its intent?

    - Order Item ID (543074831).
     
  5. subby01

    subby01 Member

    Joined:
    Dec 27, 2018
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Sydney
    cPanel Access Level:
    Website Owner
    Hi @cPanelLauren,

    The Order Item ID number is (543074831).

    If you could look it up for me it would be much appreciated, as clearing the queue didn't fix the issue.

    thanks.
     
  6. cPanelLauren

    cPanelLauren Forums Analyst II Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    5,715
    Likes Received:
    436
    Trophy Points:
    233
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi @subby01

    It looks like that certificate is being shown as being ordered on 12-28 at 11:31 PM and delivered 12:31 at 01:31 (2 hour window)

    Request Created: 2018-12-28 23:31:14
    Estimated Delivery Time: 2018-12-29 01:31:14

    Can you confirm that the certificate was installed on the domain?

    Thanks!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. subby01

    subby01 Member

    Joined:
    Dec 27, 2018
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Sydney
    cPanel Access Level:
    Website Owner
    Hi, @cPanelLauren no there is still no ssl installed on the domain.


    I tried loading up a LetsEncrypt SSL and it worked fine. I have removed it again as I would prefer to get this working.

    As I said, the autoSSL updated the last few times no problems, but this time it didn't and there doesn't seem to be a reason why?

    Is there anything else I can try or more info you can see?

    I actually have the same issue on two entirely different domains (same host). Both had automatically renewed in the past, but neither did this time round.

    Thanks.
     
    #7 subby01, Jan 2, 2019
    Last edited by a moderator: Jan 3, 2019
  8. cPanelLauren

    cPanelLauren Forums Analyst II Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    5,715
    Likes Received:
    436
    Trophy Points:
    233
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi @subby01

    Since our internal system indicates that it's been installed there's not much else we can do through the forums. In order to find out what's going on with the SSL, I think it would be best if you opened a ticket with us. You can do so using the link in my signature. Once the ticket is opened please post the Ticket ID here so I can follow up with the ticket and update this thread with the outcome.


    Thanks!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice