The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

problems with clamd when restarting exim

Discussion in 'General Discussion' started by kisonay, May 15, 2013.

  1. kisonay

    kisonay Member

    Joined:
    Mar 21, 2013
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Just started to setup a new VPS (CENTOS 6.4 x86_64 kvm – s1 WHM 11.38.0 (build 7)) and am running into a problem with clamd.

    I have installed the clamavconnector via the addons in WHM. I didn't see anything odd in the output.

    When I restart EXIM I get the following:

    Code:
    root@s1 [~]# /etc/init.d/exim restart
    Shutting down clamd: [FAILED]
    Shutting down exim: [  OK  ]
    Shutting down spamd:][FAILED]
    Starting clamd: LibClamAV Error: cli_loaddb(): No supported database files found in /usr/share/clamav
    ERROR: Can't open file or directory
                                   [FAILED]
    Starting exim: [  OK  ]

    I have confirmed that /usr/share/clamav is empty. I uninstalled / reinstalled clamavconnector via WHM and the folder is still empty.

    I searched the forum and google and tried the following:

    Code:
    cd /usr/local/cpanel/mod*/clam* (/usr/local/cpanel/modules-install/clamavconnector-Linux-x86_64)
    ./uninstall
    ./install
    didn't resolve the issue. I also tried /scripts/upcp --force with no success.

    If I run /usr/bin/freshclam I get the following

    Code:
    ClamAV update process started at Wed May 15 07:20:11 2013
    main.cvd is up to date (version: 54, sigs: 1044387, f-level: 60, builder: sven)
    daily.cld is up to date (version: 17213, sigs: 1263724, f-level: 63, builder: neo)
    bytecode.cld is up to date (version: 214, sigs: 41, f-level: 63, builder: neo)
    When I see what version of clamd is installed I get the following

    Code:
    root@s1 [~]# clamd --v
    ClamAV 0.97.8
    root@s1 [~]# which clamd
    /usr/local/sbin/clamd
    I also find it odd that spamd is referenced in the Exim restart as I have disabled SpamAssassin.


    I'm at a loss now, not sure what I need to do to resolve the issue.



    Any help/guidance would greatly be appreciated.
     
  2. kisonay

    kisonay Member

    Joined:
    Mar 21, 2013
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    If anyone else has this problem, I finally figured it out. turns out freshclam was loading the database files to a location different than what clamav was looking form.

    I went to /etc/freshclam.conf and updated it as follows

    Code:
    # Path to the database directory.
    # WARNING: It must match clamd.conf's directive!
    # Default: hardcoded (depends on installation options)
    #DatabaseDirectory /var/clamav
    DatabaseDirectory /usr/share/clamav
    Note, that I commented out the original DatabaseDirectory value and created a new one pointing to where clamd was looking for it.

    Once the change was made I ran freshclam and it download the database to the new location.
     
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    653
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    It's possible there was a previous installation of ClamAV (either via Source or RPM) that caused this problem. If anyone notices this issue when there are no previous installations of ClamAV, feel free to open a ticket using the link in my signature so we can take a closer look.

    Thank you.
     
Loading...

Share This Page