The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problems with Cpanel on 2.6 Kernels System

Discussion in 'General Discussion' started by Elikster, Feb 11, 2004.

  1. Elikster

    Elikster Well-Known Member

    Joined:
    Feb 8, 2003
    Messages:
    119
    Likes Received:
    1
    Trophy Points:
    18
    Okay...there is two different problems that is apparent for Cpanel systems under 2.6 kernel based systems. They are as follows:

    1. Horde - The error " There was an error sending your message: sendmail returned error code 255" ocurred while sending out mails using horde. However, it does send emails, just it don't save the copies of the emails when sent.

    2. RPM Errors by Cpanel mode. It will produce errors for RPMs even with the export part saying it is 2.4.2 kernel. It does not show up under commandline but when done though Cpanel, the errors show up.

    This need to be resolved for it to be working properly on 2.6 based kernels.
     
  2. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    This should fix rpm:

    http://www.fedora.us/wiki/LegacyRPMUpgrade
     
  3. Elikster

    Elikster Well-Known Member

    Joined:
    Feb 8, 2003
    Messages:
    119
    Likes Received:
    1
    Trophy Points:
    18
    Thanks for RPM Fix Solution

    That seems to resolve the issue here. What about the Horde part? That is the only other sticking problem as I have found from using Cpanel on production servers with 2.6.2 kernel on it.

    Any solution for it? I will check with Horde Developers as well but I hope you might have something for it. :)
     
  4. Elikster

    Elikster Well-Known Member

    Joined:
    Feb 8, 2003
    Messages:
    119
    Likes Received:
    1
    Trophy Points:
    18
    Exim4 Problem?

    Greetings,

    I checked with Horde and it seems it is not the problem, but more of Exim itself that might be conflicting with the 2.6 kernel itself due to the sockets.

    Seems it is confirmed. The current release of Exim 4.24 does have problems with 2.6 due to the sockets implementation. The 4.30 seems to have resolved this issue, but I am still testing it to see if I can make a drop in replacement or not for old 4.24 version in the system or not.
     
    #4 Elikster, Feb 11, 2004
    Last edited: Feb 11, 2004
  5. Snowman30

    Snowman30 Well-Known Member
    PartnerNOC

    Joined:
    Apr 7, 2002
    Messages:
    681
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    DataCenter Provider
    im running the 2.4.25 kernel and im getitng these 255 errors in horde so its not isolated to the 2.6 kernel
     
  6. GOT

    GOT Get Proactive!

    Joined:
    Apr 8, 2003
    Messages:
    900
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Norfolk, VA
    cPanel Access Level:
    DataCenter Provider
    Can confirm. Have the same problem with RHEL using a special 2.6 kernel.
     
  7. LordJMann

    LordJMann Well-Known Member

    Joined:
    Jun 15, 2003
    Messages:
    74
    Likes Received:
    0
    Trophy Points:
    6
    Having the same issue as well. Email is sent but the error is given.
     
  8. GOT

    GOT Get Proactive!

    Joined:
    Apr 8, 2003
    Messages:
    900
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Norfolk, VA
    cPanel Access Level:
    DataCenter Provider
    I switched back to 2.4 kernel and the error went away. I really would prefer to use the 2.6 kernel though.
     
Loading...

Share This Page