Keith007

Active Member
Mar 30, 2013
28
9
53
cPanel Access Level
Root Administrator
Hi All,

Is there anyway to install EA3 as EA4 is just screwing up everything
All my other servers are based on EA3 with Fastcgi and all fine
New server only has EA4 and tried Mod-FPM and nothing works

Any help is welcome before I eat my keyboard

Keith
 

24x7server

Well-Known Member
Apr 17, 2013
1,911
96
78
India
cPanel Access Level
Root Administrator
Twitter

Keith007

Active Member
Mar 30, 2013
28
9
53
cPanel Access Level
Root Administrator
This server came only with EA4 installed so unfortunately cant roll back. not sure if there is a way to install EA3

What modules are required to run Mod FPM properly cant use Suphp as every page is over 1 second just TTFB . I tried the default ones in the EA4 profiles but these just screw everything up including permalinks in wordpress, and unable to install plugins with out errors - everything is hit and miss

Cheers

Keith
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,908
2,216
463
I tried the default ones in the EA4 profiles but these just screw everything up including permalinks in wordpress, and unable to install plugins with out errors - everything is hit and miss
Hello,

Could you let us know some of the specific error messages you are seeing? You may also want to consider trying out Mod_FCGId if that's what you used in EA3:

Apache Module: FCGId - EasyApache 4 - cPanel Documentation

Thank you.
 

Keith007

Active Member
Mar 30, 2013
28
9
53
cPanel Access Level
Root Administrator
Hi

I have updated Cpanel to latest build 64.0.17 from 64.0.15 and now its bringing up less errors

Wordpress - when I install plugins displayed a lot of errors now I just get
"Installation failed: The package could not be installed. PCLZIP_ERR_MISSING_FILE (-4) : Missing archive file '/tmp/akismet.3.3-NZJrXY.tmp'"

I'm running Centos 7.3 x86_64 standard

EA4 with

Current Profile
Code:
The currently installed packages on the server.

Apache 2.4
config
config-runtime
mod_bwlimited
mod_cgi
mod_deflate
mod_expires
mod_headers
mod_mpm_prefork
mod_proxy
mod_proxy_fcgi
mod_proxy_http
mod_ruid2
mod_security2
mod_ssl
mod_unique_id
tools

PHP 7.0
libc-client
pear
php-bcmath
php-bz2
php-calendar
php-cli
php-common
php-curl
php-devel
php-fpm
php-ftp
php-gd
php-gettext
php-imap
php-litespeed
php-mbstring
php-mcrypt
php-mysqlnd
php-opcache
php-pdo
php-posix
php-sockets
php-xml
runtime

Others
apr
apr-util
cpanel-tools
documentroot
libcurl
libmcrypt
modsec-sdbm-util
php-cli
php-cli-lsphp
profiles-cpanel
I believe this config should work with Mod FPM


Regards

Keith
 
Last edited by a moderator:

Keith007

Active Member
Mar 30, 2013
28
9
53
cPanel Access Level
Root Administrator
Re installed selecting a default profile from list all installed fine. I then enable mod fpm in the multi php for my domain using php 7 - sites urls in wordpress fail that use permalinks
Tried other php5 still the same issue

Do I have to format full server and reinstall cPanel

Regards

Keith