Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Problems with Exim mailserver and TLS

Discussion in 'E-mail Discussion' started by diracuser, Jul 12, 2017.

  1. diracuser

    diracuser Active Member

    Joined:
    Oct 22, 2014
    Messages:
    40
    Likes Received:
    1
    Trophy Points:
    8
    cPanel Access Level:
    Root Administrator
    Hi.
    I'm configurating my exim server. I want to enable the TLS Protocol so I have enabled
    in Service Configuration--> Mailserver Configuration --> SSL Protocols: !SSLv2 !SSLv3 !TLSv1

    After that, I configure in my outlook 2013 my account, I check for SMTP Port : 465 and check: TLS.
    I get an error.

    If I look exim log i found the following error:

    2017-07-12 13:36:21 SMTP connection from [xxx.xxxx.xxx.xxx]:22710 (TCP/IP connection count = 1)
    2017-07-12 13:37:21 TLS error on connection from [xxx.xxx.xxx.xxx]:22710 (SSL_accept): error:00000000:lib(0):func(0):reason(0)
    2017-07-12 13:37:21 TLS client disconnected cleanly (rejected our certificate?)


    Could anyone help me?

    Thanks
     
  2. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    45,167
    Likes Received:
    1,933
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello,

    It's possible your email client requires the TLS 1.0 protocol. Have you tried reproducing the issue with another email client (e.g. Thunderbird) to rule out any compatibility issues with Outlook 2013? Also, what OS are you using when reproducing the issue?

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. diracuser

    diracuser Active Member

    Joined:
    Oct 22, 2014
    Messages:
    40
    Likes Received:
    1
    Trophy Points:
    8
    cPanel Access Level:
    Root Administrator
    Thank you for your response.
    In my Outlook 2013 I have changed my SMTP port: I had configurated 465 port, but I have read that it's better port 587.
    I changed and now it works fine ...
    It's ok port 587 to SSL and TLS conexion cipher?
     
  4. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    45,167
    Likes Received:
    1,933
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello,

    Port 587 is acceptable as long as you are choosing "SSL" under the "Use the following type of encrypted connection" option when configuring SMTP in the Outlook 2013 application.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice