The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problems with php 5.4 in WHM 11.48.0 (build 13)

Discussion in 'General Discussion' started by speckados, Feb 20, 2015.

  1. speckados

    speckados Well-Known Member

    Joined:
    May 21, 2003
    Messages:
    291
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Acequias :: Granada :: España
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    Hi.

    I try some errors en plugins taht use:

    Code:
    /usr/local/cpanel/3rdparty/bin/php-cgi /path/script
    Return error with ioncube

    Code:
    Site error: the file <b> /path/script/script.php</b> requires the ionCube PHP Loader ioncube_loader_lin_5.4.so to be installed by the website operator. If you are the website operator please use the <a href="http://www.ioncube.com/lw/">ionCube Loader Wizard</a> to assist with installation.
    Apreciate help
     
  2. cPJacob

    cPJacob cPanel Product Owner
    Staff Member

    Joined:
    May 2, 2014
    Messages:
    509
    Likes Received:
    64
    Trophy Points:
    28
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    Hello,

    As the error advises, you are trying to run a script that is encoded with IonCube and it requires those loaders to operate properly.

    Here's a guide I found that can assist you with getting this setup:
    Ioncube Installation Tutorial - WHMCS Documentation
     
  3. speckados

    speckados Well-Known Member

    Joined:
    May 21, 2003
    Messages:
    291
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Acequias :: Granada :: España
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    Ok.. but problem, its other estimate Cpanel Staff...

    Ioncube MUST BE installed for /usr/local/cpanel/3rdparty/bin/php-cgi
    Feel free go to whm and se Preferences for WHM and you can see "IONCUBE loaders"
    Check and ALL script of third parties, encoded with ioncube must be work... (alsmot on latest 10 years with WHM/Cpanel)

    The script has worked on last 8 years.
    Now, problem with PHP-CGI Cpanel...
    Best regards.

    UPDATED 17:02 GMT+1
    I see a question... on latest version tehre php 5.4 6 5.3 on /usr/local/cpanel/3rdparty/php/

    But /usr/local/cpanel/3rdparty/php/53/incube it's empty.

    I think this it's a Cpanel bug.
     
    #3 speckados, Feb 20, 2015
    Last edited: Feb 20, 2015
  4. cPanelToddR

    cPanelToddR Member
    Staff Member

    Joined:
    Oct 8, 2009
    Messages:
    21
    Likes Received:
    1
    Trophy Points:
    3
    cPanel switched to using php54 for it's internal PHP in 11.42. We later dropped all support for the use of php53 in 11.46. The ioncube you're looking for can be found here:

    Code:
    $>rpm -vV cpanel-php54-ioncube
    .........    /usr/local/cpanel/3rdparty/php/54/ioncube/ioncube_loader_lin_5.4.so
    .........  d /usr/local/cpanel/3rdparty/share/php54-ioncube/copyright
    
    The php.ini files should automatically update to be aware of the new location so that should not be a problem.

    We would be happy to help investigate this further. Can you open a ticket if this is still a problem?
     
  5. speckados

    speckados Well-Known Member

    Joined:
    May 21, 2003
    Messages:
    291
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Acequias :: Granada :: España
    cPanel Access Level:
    DataCenter Provider
    Twitter:
Loading...

Share This Page