The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problems with php cli :(

Discussion in 'General Discussion' started by maxymas, Oct 20, 2007.

  1. maxymas

    maxymas Member

    Joined:
    Oct 3, 2006
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Madrid
    Hello,
    The problem is when I try to run some php command console. (Php-q) and displays nothing


    echo '<?php echo "test\n"; ?>' | php -q


    The problem comes when I try to install software gestion streaming. The first testing it does is try to execute this command by php through console and said that php is not working well.

    Your PHP CLI binary does not appear to be working correctly. Please
    correct this problem and then restart this installation script.

    I tried to upgrade versions of apache and php, specifically the Apache version 2.0.61 and version 5.2.4 of PHP, but still leaving the same problem.
    Mandé a ticket support technicians cpanel, but nothing could be done, because according to them the same command, we worked with them in their servers that were not cpanel.

    Guess some form of resolution to this? The attempt to install software that only works with versions PHP CLI not let me run under PHP versions CGI.

    Server software installed.

    Apache verion: 1.3.39
    Php version:
    PHP 4.4.7 (cli) (built: Oct 20 2007 12:11:41)
    Copyright (c) 1997-2007 The PHP Group
    Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies
    with the ionCube PHP Loader v3.1.32, Copyright (c) 2002-2007, by ionCube Ltd., and
    with Zend Extension Manager v1.2.0, Copyright (c) 2003-2006, by Zend Technologies
    with Zend Optimizer v3.3.0, Copyright (c) 1998-2007, by Zend Technologies


    Thanks!
     
    #1 maxymas, Oct 20, 2007
    Last edited: Oct 20, 2007
Loading...

Share This Page