The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problems with Return-path on email

Discussion in 'E-mail Discussions' started by danimal, Jul 18, 2006.

  1. danimal

    danimal Well-Known Member

    Joined:
    Jul 14, 2003
    Messages:
    79
    Likes Received:
    0
    Trophy Points:
    6
    Hello!

    I've been searching but haven't found an answer to my email problem, so I figured I'd just post it. If there is a thread already about this issue, I apologize and welcome any reference(s).

    The issue: It appears that a lot of bounce emails are coming into the system to <user@server>, which apparently doesn't utilize the :fail: command for <user@domain>.

    What strikes me as odd is why this is being injected in the headers in the first place.

    An example:

    My client with account "pools" and domain "pools.com", has a user account "joe". This is on my server "server1.com". I've set "pools", which is the cpanel account name, and thus the default account, to be ":fail:". What I'm seeing is that if an email goes out from "joe@pools.com" via some script, and it bounces, there is a "Return-path: pools@server1.com" value set in the outgoing headers, so the bounceback message comes to "pools@server1.com", which goes to the "pools" inbox (/home/pools/mail/inbox), totally ignoring the :fail:.

    So I found a reference for how to alter /etc/aliases to fix this, but it's on an account-by-account basis. I'd rather make a system-wide fix.

    Can someone recommend how to do this? The scenario above _should_ work as follows:

    The email goes out from "joe@pools.com" and either has no "Return-path" header or it is set to "joe@pools.com", or even set to "pools@pools.com", which is the default account for the "pools.com" domain. Either of these two would work, with the first being preferred.

    Any ideas?

    Thanks!

    -Danimal :cool:
     
  2. danimal

    danimal Well-Known Member

    Joined:
    Jul 14, 2003
    Messages:
    79
    Likes Received:
    0
    Trophy Points:
    6
    P.s.

    This isn't the phpsuexec issue, as that has to do with "nobody" vs. user accounts. I've already taken care of that.

    I'm hoping there is either an easy Exim setting or a WHM setting that I am just missing or ignorant of.

    :)
     
  3. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Is this just from web scripts? If so, then the scripts can specify the return path themselves in the email header. Also, are the scripts setging the From: address correctly?
     
Loading...

Share This Page