Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Problems with ruby gems

Discussion in 'General Discussion' started by wrender, Apr 23, 2015.

Tags:
  1. wrender

    wrender Well-Known Member

    Joined:
    Sep 29, 2007
    Messages:
    69
    Likes Received:
    3
    Trophy Points:
    58
    On our cPanel servers we are getting the following Ruby errors:

    Code:
    gem install bootstrap-sass
    ERROR:  Error installing bootstrap-sass:
    execjs requires Ruby version >= 1.9.3.
    Is there a supported way to upgrade to Ruby version 1.9.3?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,827
    Likes Received:
    1,898
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. ravindradhainwa

    ravindradhainwa Well-Known Member

    Joined:
    Jan 24, 2008
    Messages:
    45
    Likes Received:
    1
    Trophy Points:
    56
    Is still cPanel can't support Ruby version 1.9.X ?
     
  4. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,827
    Likes Received:
    1,898
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    You can install Ruby through YUM as a system package. Could you elaborate on your specific requirements and what you need installed?

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. dannyil

    dannyil Registered

    Joined:
    Aug 9, 2016
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Jerusalem, Israel
    cPanel Access Level:
    Website Owner
    It would be so awesome
    if cpanel supported Ruby 2.3.1 (latest stable release)
    and Rails 4.* and even Rails 5.0.0

    We're in 2016 and you'd think that the latest stable releases should be supported?

    Thank you
     
  6. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,827
    Likes Received:
    1,898
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello,

    I recommend voting and adding feedback to the following feature request:

    ruby app support through phusion passenger

    You can subscribe to the feature request to ensure you receive updates to it's status.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice