The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problems with sending emails from dedicated ip

Discussion in 'E-mail Discussions' started by Karabaja, Apr 21, 2010.

  1. Karabaja

    Karabaja Active Member

    Joined:
    Mar 3, 2006
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    1
    I have PTR records for both shared ip and dedicated ips.
    Dns tests report everything fine with the domain in question.

    Anyway I've checked the option in exim config:

    mail_reverse_dns file was still empty after enabling that option so I edited it manually.

    Some mail servers are rejecting our emails because they report mismatch in reverse dns records.

    Email headers have this:

    Received: from mail.mydomain.com
    by server.hostname.com with esmtpsa

    Is there anyway to bypass using main shared ip/hostname when sending out emails?

    I've just did a test of this dedicated ip here:
    MX Lookup Tool - Check your DNS MX Records online - MxToolbox with their smtp test and it gives this warning:
    Reverse DNS does not match SMTP Banner

    I also tried editing /etc/mailhelo and mailips and checking those other two boxes in domains and ips section of exim config editor but it still ends up with same header and same problem.
     
  2. Vinu007

    Vinu007 Member

    Joined:
    Aug 9, 2006
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    0
    Hi,

    Try to change settings in Tweak Settings option available in your WHM. Go through each and every point and make the appropriate changes as per your requirement. Also make sure the SMTP Tweak is disabled in WHM and not enabled.

    Hope this should resolve your issue.
     
  3. chinmay

    chinmay Well-Known Member

    Joined:
    Jul 22, 2008
    Messages:
    101
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    localhost
    Hi,

    Hope the below helps.

    Login to WHM as root. Access option Service Configuration >> Exim Configuration Editor. Look for "Send outgoing mail from the ip that matches the domain name in /etc/mailips (*: IP can be added to the file to change the main outgoing interface)". Check the option and click on Save

    Once done, login to server via SSH and open the file /etc/mailips
    Enter the entry as below

    domain.com: 10.10.10.2
    10.10.10.2 is the dedicated IP and domain.com is the domain to which it is assigned too.

    Open /etc/mail_reverse_dns and add as below
    10.10.10.2: domain.com

    This should allow you to send emails using the dedicated IP.
     
Loading...

Share This Page