The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

problems with sql ???

Discussion in 'Database Discussions' started by epropnet, Apr 28, 2007.

  1. epropnet

    epropnet Member

    Joined:
    Apr 28, 2007
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    Currently i am on a reseller account with cpanel

    i am trying to get a autoresponder to work and get the following error;

    Unable to connect to MySQL server
    Make sure you are using correct Server Name,Username and Password
    Access denied for user 'nobody'@'localhost' (using password: NO)
    Please go back and check again


    when i enter the database info i use as when i setup a database i have checked and set permissions to all

    When i run the install for the script i enter the following information

    database hostname: localhost
    database name: hahahbi_eggs
    user name: hahahbi_eggs
    database password: eggs


    I have installed many php & cgi scripts with a database before

    The software states that the following must be present;

    1) PHP scripts
    2) CGI scripts with MySQL perl module
    3) MySQL database

    When cpanel installed will the "MySQL perl module" be installed on default or if it is could anybody advice me on what the problem could be

    Thanks :confused:
     
  2. AMD64

    AMD64 Active Member

    Joined:
    Jun 19, 2005
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    Your script installer does not appear to be updating your script with the database details.

    Your script may need "register_globals On" and the server may have it off by default or your script settings/config file may not be writeable possibly.
     
  3. epropnet

    epropnet Member

    Joined:
    Apr 28, 2007
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    thanks

    Thanks for your help. i knew it was something small. i have it set in the public_html directory but it also be i the dir where the script is
    Greetings
    Johan
     
Loading...

Share This Page