Problems with UTF-8, auto-responders, etc.

Rbrt

Member
May 15, 2008
5
0
51
We are having problems with French characters, specifically when setting auto-responders. Here's my original post to another thread:

(We are using 11.18.6-RELEASE_24255.)

Our users set auto-responders in cPanel which frequently contain French characters. Unfortunately, auto-responses have been turning up with broken characters (like the famous �) instead of é or ù (just for example). If I go to "Add Auto-responder" and fill in the fields, I note that the Character Set is set to UTF-8 (which is as it should be, as far as I'm concerned).

But, if I change the Character Set to us-ascii or iso-8859-1 the auto-responses turn up with French characters intact. Why is UTF-8 the set that breaks French characters?

I saw a thread about a bug in UTF-8 support for cPanel but that looked like it referred to an earlier version. I also note that a View Source on the cPanel page shows that it is served up in iso-8859-1, so I'm wondering if there is a mismatch within cPanel or somewhere else on the server (Apache? Mail spooler? I'm not knowledgeable enough to know if this would be an issue). Is there a setting I can change in cPanel?

I would like to avoid having our users manually change the Character Set each time they set an auto-responder. I'd also like to make UTF-8 work, since it's the one we want to use.
If I am unable to determine what is making UTF-8 break, are there any steps I could take in WebHost Manager to change the default character set to something other than UTF-8 for auto-responders? Is there something in WebHost Manager that is conflicting with what the language or character set in the cPanel auto-responder interface? I don't want to have to ask my users to change the character set themselves.
 

cPanelKenneth

cPanel Development
Staff member
Apr 7, 2006
4,608
77
458
cPanel Access Level
Root Administrator
We are having problems with French characters, specifically when setting auto-responders. Here's my original post to another thread:



If I am unable to determine what is making UTF-8 break, are there any steps I could take in WebHost Manager to change the default character set to something other than UTF-8 for auto-responders? Is there something in WebHost Manager that is conflicting with what the language or character set in the cPanel auto-responder interface? I don't want to have to ask my users to change the character set themselves.
What encoding is the browser using?

What language is set in the user's cPanel interface?
 

Rbrt

Member
May 15, 2008
5
0
51
Browsers are Firefox 3 RC1 and Safari 3.1.1, set by default to ISO-8859-1 (but I have also tried UTF-8 in both browsers).

The language of the cPanel interface is set to English.
 

cPanelKenneth

cPanel Development
Staff member
Apr 7, 2006
4,608
77
458
cPanel Access Level
Root Administrator
Browsers are Firefox 3 RC1 and Safari 3.1.1, set by default to ISO-8859-1 (but I have also tried UTF-8 in both browsers).

The language of the cPanel interface is set to English.
English or English-UTF8 ?
 

Rbrt

Member
May 15, 2008
5
0
51
Strangely enough, changing the cPanel theme seems to have fixed this! The default theme was not supporting whatever language changes we made elsewhere.

Oddly enough, the character set is now listed as ansi_x3.110-1983 in the auto-responder interface. This isn't exactly right, but since French characters are now rendering correctly I'm tempted to leave it alone. ;)