Processing Sprites error messages during upcp process

Paul Srch

Member
Jul 4, 2012
9
1
3
Cumming, Georgia, United States
cPanel Access Level
Root Administrator
I'm getting the following in my daily update log (running version 11.46.1.4)

Code:
[20141230.232404]   Processing: Rebuilding sprites
[20141230.232404]    - Processing command `/usr/local/cpanel/bin/sprite_generator --all`
[20141230.232404]      [24068] The parameter “id” was given an invalid value of “itroot_widget1”.
[20141230.232404]      [24068]  at /usr/local/cpanel/Cpanel/Exception.pm line 102.
[20141230.232404]      [24068] 	Cpanel::Exception::new("Cpanel::Exception::InvalidParameter", "The parameter \x{e2}\x{80}\x{9c}[_1]\x{e2}\x{80}\x{9d} was given an invalid value of \x{e2}\x{80}\x{9c}[_2"..., ARRAY(0x3767190)) called at /usr/local/cpanel/Cpanel/Exception.pm line 53
[20141230.232404]      [24068] 	Cpanel::Exception::create("InvalidParameter", "The parameter \x{e2}\x{80}\x{9c}[_1]\x{e2}\x{80}\x{9d} was given an invalid value of \x{e2}\x{80}\x{9c}[_2"..., ARRAY(0x3767190)) called at /usr/local/cpanel/Cpanel/Themes/Assets/Base.pm line 33
[20141230.232404]      [24068] 	Cpanel::Themes::Assets::Base::new(__CPANEL_HIDDEN__, __CPANEL_HIDDEN__, __CPANEL_HIDDEN__, __CPANEL_HIDDEN__, 2, __CPANEL_HIDDEN__, __CPANEL_HIDDEN__, __CPANEL_HIDDEN__, __CPANEL_HIDDEN__, ...) called at /usr/local/cpanel/Cpanel/Themes/Serializer/DynamicUI.pm line 218
[20141230.232404]      [24068] 	Cpanel::Themes::Serializer::DynamicUI::_dui2group(Cpanel::Themes::Serializer::DynamicUI=HASH(0x334a570), HASH(0x37535a8)) called at /usr/local/cpanel/Cpanel/Themes/Serializer/DynamicUI.pm line 41
[20141230.232404]      [24068] 	Cpanel::Themes::Serializer::DynamicUI::build_data_tables(Cpanel::Themes::Serializer::DynamicUI=HASH(0x334a570)) called at /usr/local/cpanel/Cpanel/Themes/Serializer/Base.pm line 88
[20141230.232404]      [24068] 	Cpanel::Themes::Serializer::Base::links(Cpanel::Themes::Serializer::DynamicUI=HASH(0x334a570)) called at /usr/local/cpanel/bin/sprite_generator line 152
[20141230.232404]      [24068] 	Cpanel::Bin::SpriteGenerator::_run_new_sprite_generator(HASH(0x2401738)) called at /usr/local/cpanel/bin/sprite_generator line 83
[20141230.232404]      [24068] 	Cpanel::Bin::SpriteGenerator::run("*Cpanel::Themes::Serializer::DynamicUI::links") called at /usr/local/cpanel/bin/sprite_generator line 9
I thought I saw a post on this, but now I can't find it. does anyone know a way to fix this?
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,880
2,260
463
I am happy to see the issue was addressed after forcing an update of cPanel. Thank you for updating us with the outcome.