Profile includes following packages not supported on server

cetiner

Member
Dec 24, 2018
23
3
3
turkey
cPanel Access Level
Root Administrator
Server runs with CentOS 6
Some weeks long i have the error messages in my WHM / Software / EasyApache4 (bevore all was ok...)

I show you an example:

All PHP Options + OpCache
cpanel Apache 2.4, PHP 7.3, PHP 7.2, PHP 7.1 und All PHP Opts

This profile includes the following packages that are not supported on this server:
  • mod_cgid
  • mod_mpm_worker
  • mod_suexec
  • mod_suphp
  • php71-build
  • php71-php-dba
  • php71-php-enchant
  • php71-php-gettext
  • php71-php-gmp
  • php71-php-intl
  • php71-php-ldap
  • php71-php-odbc
  • php71-php-pgsql
  • php71-php-process
  • php71-php-pspell
  • php71-php-snmp
  • php71-php-tidy
  • php71-php-xmlrpc
  • php72-build
  • php72-php-dba
  • php72-php-enchant
  • php72-php-gettext
  • php72-php-gmp
  • php72-php-intl
  • php72-php-ldap
  • php72-php-odbc
  • php72-php-pgsql
  • php72-php-process
  • php72-php-pspell
  • php72-php-snmp
  • php72-php-tidy
  • php73-build
  • php73-php-dba
  • php73-php-enchant
  • php73-php-gettext
  • php73-php-gmp
  • php73-php-intl
  • php73-php-ldap
  • php73-php-odbc
  • php73-php-pgsql
  • php73-php-process
  • php73-php-pspell
  • php73-php-snmp
  • php73-php-soap
  • php73-php-tidy
  • php73-php-xmlrpc
Could the reason be any wrong installed RPM package ?
 

cetiner

Member
Dec 24, 2018
23
3
3
turkey
cPanel Access Level
Root Administrator
Hello @cPanelMichael Puhhh I did a lot of investigations.... I try to make it in a short version about the main info

Installing wpscan. But Ruby version XX is just supported by wpscan.
So I installed RVM (Ruby Version Manager) and my unlucky 2 days has started, even if wpscan runs.

The problem was removing of SQlite package (deprecated info), I thought I can remove it and after I make an clean reinstallation....
But I couldn't go on with anything....nothing worked. And a reinstallation failed, cause something was missed by the reinstalling process.
And if I tried to install the missed library - I received error of missed SQlite.

So I did a restoring of my WHM server files from the cPanel backup (by hand).

Than I was able to use the server like normal..... but some things didn't worked like always.
If I had a look the the WHM / Software / EA4 I saw my surprise: This profile includes the following packages that are not supported on this server.

I checked some log files in generally checkup and found an problem about Horde update. I remembered that i had take out some repository files
from directory in /etc/repo.d, cause on my tries of reinstalling SQlite i received error messages about the repos..... I do not remember exactly which it was....

But solution: taking out the atomic repository, rebuilding all and that's it

It is not the first time I remark the repositories can be a reason in many cases without an direct indication....

If somebody have another problem after installing a software script (e.G. like wpscan) and had a own workaround with the repositories - it could help
to go back to the "original" state of repos.