The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

proftpd 1.2.10 is not resolving IPs - fix available??

Discussion in 'General Discussion' started by qwerty, Oct 25, 2004.

  1. qwerty

    qwerty Well-Known Member

    Joined:
    Jan 21, 2003
    Messages:
    213
    Likes Received:
    0
    Trophy Points:
    16
    anyone know what the deal is with proftpd 1.2.10 and dns resolving? by default the proftpd.conf seems to have dns resolving turned OFF .. but even if you turn it on and restart proftpd, a few days later I find its no longer resolving IPs (for example when I run last -10a I see IPs only). Any way to fix this crap?
     
  2. haze

    haze Well-Known Member

    Joined:
    Dec 21, 2001
    Messages:
    1,550
    Likes Received:
    3
    Trophy Points:
    38
    Are you running name servers on that machine ? You sure you have your resolv.conf set up correctly ? Also, are you sure those IP's actually resolve to a hostname ?
     
  3. qwerty

    qwerty Well-Known Member

    Joined:
    Jan 21, 2003
    Messages:
    213
    Likes Received:
    0
    Trophy Points:
    16
    Yes, yes and yes. This has only started happening with proftpd 1.2.10 (which came out a few weeks ago).

    Namely, 1.2.10 seems to have "UseReverseDNS off" as default in the proftpd.conf

    If you change it to UseReverseDNS on and restart proftpd, it WILL start resolving all IPs correctly BUT (and this is a BIG BUTT) some time later (hours, days?) it simply stops resolving IPs again even though the proftpd.conf still has UseReverseDNS on.

    Which is totally weird and leads me to believe it might be an actual bug with proftpd rather than cpanel ..

    If you use proftpd, why not try it? Just run something like "last -20a" in the shell. If you see IPs only next to each login you're affected too.

    I've confirmed this on several machines, hosted in different places .. and it has only started happening since proftpd 1.2.10 was installed. Before 1.2.10 everytime I ran the "last" command, each ftp login would show the hostname, not the IP, of the person who logged in.
     
  4. SarcNBit

    SarcNBit Well-Known Member

    Joined:
    Oct 14, 2003
    Messages:
    1,010
    Likes Received:
    3
    Trophy Points:
    38
    Have you confirmed that 'UseReverseDNS On' is still set once the issue crops back up? cPanel tends to undo configuration changes when you aren't looking :eek:
     
  5. qwerty

    qwerty Well-Known Member

    Joined:
    Jan 21, 2003
    Messages:
    213
    Likes Received:
    0
    Trophy Points:
    16
    Yes of course I've checked. The UseReverseDNS is still set to ON - cpanel hasn't changed anything.
     
  6. qwerty

    qwerty Well-Known Member

    Joined:
    Jan 21, 2003
    Messages:
    213
    Likes Received:
    0
    Trophy Points:
    16
    anyone got any ideas how to fix this and whether it's a problem with proftp itself ?? :/
     
  7. qwerty

    qwerty Well-Known Member

    Joined:
    Jan 21, 2003
    Messages:
    213
    Likes Received:
    0
    Trophy Points:
    16
    Ok i got it ...

    The "UseReverseDNS off" is present twice in the /etc/proftpd.conf .. remove the 2nd one and just leave the first one as "UseReverseDNS on".

    Seems like someone at cpanel may have been making changes to the proftpd.conf and put that setting twice by accident.. mm.
     
Loading...

Share This Page