The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

proftpd and broken uploads

Discussion in 'General Discussion' started by baidarkabob, Aug 31, 2003.

  1. baidarkabob

    baidarkabob Well-Known Member

    Joined:
    Jan 12, 2003
    Messages:
    105
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Alaska
    Greetings,

    Does proftpd need to be configured to allow resuming of broken uploads? Resuming broken downloads is working, but not broken uploads.

    I would appreciate assistance.

    bob

    cPanel.net Support Ticket Number:
     
  2. baidarkabob

    baidarkabob Well-Known Member

    Joined:
    Jan 12, 2003
    Messages:
    105
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Alaska
    further info

    I found this, but I do not know where to change AllowStoreRestart to "on".

    help.

    bob

    AllowStoreRestart
    Name
    AllowStoreRestart -- Allow clients to resume uploads
    Synopsis

    AllowStoreRestart [ on|off]

    Default

    AllowStoreRestart off

    Context

    server config, <VirtualHost>, <Anonymous>, <Directory>, <Global>, .ftpaccess

    Module

    mod_core

    Compatibility

    0.99.0 and later

    Description

    The AllowStoreRestart directive permits or denies clients from "restarting" interrupted store file transfers (those sent from client to server). By default restarting (via the REST command) is not permitted when sending files to the server. Care should be taken to disallow anonymous ftp "incoming" transfers to be restarted, as this will allow clients to corrupt or increase the size of previously stored files (even if not their own).

    The REST (Restart STOR) command is automatically blocked when HiddenStor is enabled, with the server returning a 501 error code to the client.

    cPanel.net Support Ticket Number:
     
  3. baidarkabob

    baidarkabob Well-Known Member

    Joined:
    Jan 12, 2003
    Messages:
    105
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Alaska
    more progress but would appreciate some help

    I am guessing that i need to modify proftpd.conf in the etc directory? I am using pico to attempt this. I seem to be able to find the .conf file and add the line "AllowStoreRestart on" but i do not know how or where to save the changes.

    Please advise.

    bob

    cPanel.net Support Ticket Number:
     
  4. Jeff75

    Jeff75 Well-Known Member

    Joined:
    Apr 11, 2003
    Messages:
    555
    Likes Received:
    0
    Trophy Points:
    16
    I also have a few clients who want the ability to do this. Apparantly, you have to add the following lines in between the Global tags if you want to apply it to all the FTP users. It is supposed to make it so users can resume cancelled uploads/downloads.

    AllowRetrieveRestart on
    AllowStoreRestart on

    I have tried adding the lines above in my proftpd.conf file inside and outside the Global tags and have completely shut down proFTPD but it still isn't working.

    Does anybody have any ideas how to make it so downloads/uploads will be saved when the are cancelled?

    cPanel.net Support Ticket Number:
     
  5. baidarkabob

    baidarkabob Well-Known Member

    Joined:
    Jan 12, 2003
    Messages:
    105
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Alaska
    Good to hear that you "feel my pain" Jeff. Always nice to have someone else in the boat.

    I have now got as far as you but still am not seeing results. Here is another question.

    There are several accounts on this server. Do the lines need to be added to the proftpd.conf file in each accounts /etc directory or is there a way to make changes server wide?

    OH, and - does it matter where this global tag is placed? SHould i just put it on the line after the other global tags?

    Thanks,

    Bob

    cPanel.net Support Ticket Number:
     
  6. Jeff75

    Jeff75 Well-Known Member

    Joined:
    Apr 11, 2003
    Messages:
    555
    Likes Received:
    0
    Trophy Points:
    16
    If you want to apply the setting server-wide, just place the lines inside the Global tags. You can just put the Global tags towards the top of your config file (above the virtual hosts).

    See the following link for an example: http://www.proftpd.org/docs/configs/virtual_authuserfile.conf

    I don't understand why it isn't working. Here is the link to the documentation on the setting to allow clients to resume uploads: http://www.proftpd.org/docs/directives/configuration_full.html#ALLOWSTORERESTART Everything appears to be set up correctly so I am not sure why it isn't working.

    cPanel.net Support Ticket Number:
     
  7. baidarkabob

    baidarkabob Well-Known Member

    Joined:
    Jan 12, 2003
    Messages:
    105
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Alaska
    Thanks Jeff

    Thanks Jeff but I am still confused about which proftpd.conf file i should be editing. At the root level there is an etc/ directory and a proftpd.conf file, then there are also etc/ directories in each accounts directory that contains a proftpd.conf file. Does editing the /etc/proftpd.conf file do the server wide changes?

    bob

    cPanel.net Support Ticket Number:
     
    #7 baidarkabob, Sep 3, 2003
    Last edited: Sep 3, 2003
  8. Jeff75

    Jeff75 Well-Known Member

    Joined:
    Apr 11, 2003
    Messages:
    555
    Likes Received:
    0
    Trophy Points:
    16
    Re: Thanks Jeff

    Yes, if you want to apply the changes server-wide, you will need to edit this file.

    cPanel.net Support Ticket Number:
     
  9. baidarkabob

    baidarkabob Well-Known Member

    Joined:
    Jan 12, 2003
    Messages:
    105
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Alaska
    Thanks Jeff, so it must override the accounts proftp.conf file?

    Bob

    cPanel.net Support Ticket Number:
     
  10. Jeff75

    Jeff75 Well-Known Member

    Joined:
    Apr 11, 2003
    Messages:
    555
    Likes Received:
    0
    Trophy Points:
    16
    Yes, it is the main config file. Try it out and let me know if it works for you. For some reason, mine still isn't working and I have it in my <Global></Global> tags and I have totally shut down proftpd then started it up.

    cPanel.net Support Ticket Number:
     
  11. baidarkabob

    baidarkabob Well-Known Member

    Joined:
    Jan 12, 2003
    Messages:
    105
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Alaska
    How do you test if it is working? I am just connecting via ftp, starting an upload, unplugging the internet connnection, reconnecting and attempting to resume the upload - because that mimmicks my circumsances closely (frequent loss of connection). Is there a simpler way?

    bob

    cPanel.net Support Ticket Number:
     
  12. Jeff75

    Jeff75 Well-Known Member

    Joined:
    Apr 11, 2003
    Messages:
    555
    Likes Received:
    0
    Trophy Points:
    16
    Are the uploads continuing where they left off after you unplugged your connection?

    I'm using WS_FTP Pro 8.x and it has a feature where you can pause an upload. I just click pause then start and it "should" restart at the % that it left off it, but for some reason it keeps going back to 0%.

    cPanel.net Support Ticket Number:
     
  13. baidarkabob

    baidarkabob Well-Known Member

    Joined:
    Jan 12, 2003
    Messages:
    105
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Alaska
    Jeff, i am using cuteFTPpro and have the same stopping feature. I have tested and it is not working on my end either. I am getting:Append/Restart not permitted, try again

    see below

    COMMAND:> APPE windfall.zip
    STATUS:> Connecting ftp data socket 66.129.86.150:44431...
    451 windfall.zip: Append/Restart not permitted, try again
    ERROR:> Temporary completion problem reply.
    COMMAND:> REST 262144
    350 Restarting at 262144. Send STORE or RETRIEVE to initiate transfer
    COMMAND:> STOR windfall.zip
    STATUS:> Connecting ftp data socket 66.129.86.150:44431...
    451 windfall.zip: Append/Restart not permitted, try again
    ERROR:> Temporary completion problem reply.

    cPanel.net Support Ticket Number:
     
  14. baidarkabob

    baidarkabob Well-Known Member

    Joined:
    Jan 12, 2003
    Messages:
    105
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Alaska
    Jeff, are you seeing a similar error?

    bob

    cPanel.net Support Ticket Number:
     
  15. Jeff75

    Jeff75 Well-Known Member

    Joined:
    Apr 11, 2003
    Messages:
    555
    Likes Received:
    0
    Trophy Points:
    16
    One of my clients is receiving a similar error to what you are receiving. My FTP program just shows transfer complete after clicking pause.

    I still cannot get it to work and it's getting frustrating because everything is correct according to the proFTPD docs.

    cPanel.net Support Ticket Number:
     
  16. baidarkabob

    baidarkabob Well-Known Member

    Joined:
    Jan 12, 2003
    Messages:
    105
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Alaska
    Anybody? Anything?

    cPanel.net Support Ticket Number:
     
  17. baidarkabob

    baidarkabob Well-Known Member

    Joined:
    Jan 12, 2003
    Messages:
    105
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Alaska
    :(

    :eek:

    cPanel.net Support Ticket Number: cPanel ID# 23022
     
  18. baidarkabob

    baidarkabob Well-Known Member

    Joined:
    Jan 12, 2003
    Messages:
    105
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Alaska
    fixed!

    Jeff, Tom with Cpanel tech support got this working. I am sorry that I can not report the fix. According to him the file that was supposed to have the global added did not have the global. I swear i added it to the root/etc directory so I do not know what to tell you except double check that the file you are editing is in the correct place and/or contact Tom at Techsupport.

    good luck,

    bob

    cPanel.net Support Ticket Number:
     
  19. Jeff75

    Jeff75 Well-Known Member

    Joined:
    Apr 11, 2003
    Messages:
    555
    Likes Received:
    0
    Trophy Points:
    16
    Bob,

    Thanks for the update. Can you please post the top part of your config file (the part down to where the Anon FTP starts) so I can take a look? I have the settings in the Global tags, so it's kinda strange it isn't working.

    cPanel.net Support Ticket Number:
     
  20. baidarkabob

    baidarkabob Well-Known Member

    Joined:
    Jan 12, 2003
    Messages:
    105
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Alaska
    this what your after?

    Here is the Toms reply when i replied that I was baffled that he should be able to get it to work the same way I was trying...

    "Bob
    > That was the funny thing I did not even see what you put in the file
    > there was
    > no:
    > -------------------------------------------------------------------------
    > <Global>
    > AllowStoreRestart on
    > </Global>
    > -------------------------------------------------------------------------
    >
    > /etc/proftp.conf
    > /home/cribob/etc/proftp.conf
    >
    > there was no global in ether one of them."

    This is from /ect/proftp.conf

    # This is a basic ProFTPD configuration file (rename it to
    DisplayConnect /etc/issue.net
    DisplayConnect /etc/issue.net
    # 'proftpd.conf' for actual use. It establishes a single server
    # and a single anonymous login. It assumes that you have a user/group
    # "nobody" and "ftp" for normal operation and anon.

    ServerName "ProFTPD"
    AuthUserFile /etc/proftpd/passwd.vhosts
    LogFormat BytesLog "%b"
    ServerType standalone
    DeferWelcome off
    DefaultServer on
    DefaultRoot ~ !wheel
    TimeoutLogin 1800
    TimeoutIdle 1800
    TimeoutNoTransfer 6000

    # Port 21 is the standard FTP port.

    <IfModule mod_tls.c>
    TLSEngine on
    TLSProtocol TLSv1
    TLSRequired off
    TLSRSACertificateFile /etc/ftpd-rsa.pem
    TLSRSACertificateKeyFile /etc/ftpd-rsa-key.pem
    TLSVerifyClient off
    </IfModule>
    Port 21
    # Umask 022 is a good standard umask to prevent new dirs and files
    # from being group and world writable.
    Umask 022

    # Set the user and group that the server normally runs at.
    User nobody
    Group proftpd

    # Normally, we want files to be overwriteable.
    <Directory />
    AllowOverwrite on
    </Directory>

    # This is to allow restarting of broken uploads.
    <Global>
    AllowStoreRestart on
    </Global>

    # A basic anonymous configuration, no upload directories.
    <Anonymous ~ftp>
    UseFtpUsers on
    RequireValidShell off

    User ftp
    Group ftp
    # We want clients to be able to login with "anonymous" as well as "ftp"
    UserAlias

    Etc.

    Etc.

    cPanel.net Support Ticket Number:
     
Loading...

Share This Page