Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

proftpd-connection lost while uploading

Discussion in 'General Discussion' started by tshin, Jun 1, 2005.

  1. tshin

    tshin Active Member

    Joined:
    Dec 14, 2004
    Messages:
    41
    Likes Received:
    0
    Trophy Points:
    156
    hi.
    i have a problem here.

    my box uses proftpd,when uploading files,(small,many files),it often get speed quickly down to 0kb/s,and then connection lost.
    then user reconnects proftpd,uploading..uploading..then losts connection again.

    why does it?
    can i do something?

    thank you very much!
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,460
    Likes Received:
    21
    Trophy Points:
    463
    Location:
    Go on, have a guess
    It's most likely an issue with dropped packets to the server. If that's the case, then you'd need to try a different internet connections. Alternatively, you could try switching to pure-ftpd in WHM and see if that helps.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. tshin

    tshin Active Member

    Joined:
    Dec 14, 2004
    Messages:
    41
    Likes Received:
    0
    Trophy Points:
    156
    thank you.
    but can i ask a questions based on pure-ftpd?

    how can i disable Specific Users login to ftp?
    in proftpd,i use /etc/ftpusers
    but what about pure-ftpd?

    thank you.
     
  4. nickb

    nickb Well-Known Member

    Joined:
    Feb 25, 2005
    Messages:
    347
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    India
    if your pure-ftpd is configured to use PAM authentication then you can use this...u will have to create a file named pure-ftpd in /etc/pam.d/ with following entries

    #%PAM-1.0

    # Sample PAM configuration file for Pure-FTPd.
    # Install it in /etc/pam.d/pure-ftpd or add to /etc/pam.conf

    auth required pam_listfile.so item=user sense=deny file=/etc/ftpusers onerr=succeed
    auth required pam_stack.so service=system-auth
    auth required pam_shells.so
    auth required pam_nologin.so

    account required pam_stack.so service=system-auth

    password required pam_stack.so service=system-auth

    session required pam_stack.so service=system-auth

    ---------------------------------------------------------------------------------------
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. tshin

    tshin Active Member

    Joined:
    Dec 14, 2004
    Messages:
    41
    Likes Received:
    0
    Trophy Points:
    156
    thank you.
    i'll try it. :)
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice