Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

proftpd not logging to ftpxferlog ?

Discussion in 'General Discussion' started by jamesbond, Dec 28, 2004.

  1. jamesbond

    jamesbond Well-Known Member

    Joined:
    Oct 9, 2002
    Messages:
    738
    Likes Received:
    1
    Trophy Points:
    168
    I noticed proftpd is not logging anything to the general ftp log (ftpxferlog)

    In proftpd.conf the following line is present:

    TransferLog /usr/local/apache/domlogs/ftpxferlog


    It also seems to empty ftpxferlog and ftpxferlog.offsetftpsep every 10 minutes or so.

    -rw-r--r-- 1 root root 0 Dec 28 09:21 ftpxferlog
    -rw-r--r-- 1 root root 2 Dec 27 20:45 ftpxferlog.offset
    -rw-r--r-- 1 root root 2 Dec 28 09:21 ftpxferlog.offsetftpsep


    Not sure why it's not logging, any ideas?
     
  2. jamesbond

    jamesbond Well-Known Member

    Joined:
    Oct 9, 2002
    Messages:
    738
    Likes Received:
    1
    Trophy Points:
    168
    Just a little bump (only 1 view) :)
     
  3. JP-HOST

    JP-HOST Well-Known Member

    Joined:
    Sep 23, 2004
    Messages:
    59
    Likes Received:
    0
    Trophy Points:
    156
    Location:
    Roscoe, IL, USA
    I hate to dig up this old thread, but I am seeing this too. I think it started after the 21st of Nov because I had ftp transfer info in my log watch on that date then after that nothing... Anyone have an answer?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,460
    Likes Received:
    22
    Trophy Points:
    463
    Location:
    Go on, have a guess
    Have you tried enabling:

    WHM > Tweak Settings > Do not reset /usr/local/apache/domlogs/ftpxferlog after it has been seperated into each domain name's ftp log
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. JP-HOST

    JP-HOST Well-Known Member

    Joined:
    Sep 23, 2004
    Messages:
    59
    Likes Received:
    0
    Trophy Points:
    156
    Location:
    Roscoe, IL, USA
    Thanks for that Chirpy. I think that will do the trick...
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. JP-HOST

    JP-HOST Well-Known Member

    Joined:
    Sep 23, 2004
    Messages:
    59
    Likes Received:
    0
    Trophy Points:
    156
    Location:
    Roscoe, IL, USA
    That seemed to fix the problem with ftpxferlog being empty, but now how do I get it to show me the information in the logwatch emails? Should xferlog in '/var/log/' be symlinked to ftpxferlog in '/usr/local/apache/domlogs/'? Right now my xferlog files in '/var/log/' look like this:

    Code:
    -rw-r--r--    1 root     root            0 Feb  7 11:08 xferlog
    lrwxrwxrwx    1 root     root           41 Feb  4 21:06 xferlog.1 -> ../../usr/local/apache/domlogs/ftpxferlog
    lrwxrwxrwx    1 root     root           41 Jan 25 11:17 xferlog.2 -> ../../usr/local/apache/domlogs/ftpxferlog
    lrwxrwxrwx    1 root     root           41 Jan 16 22:44 xferlog.3 -> ../../usr/local/apache/domlogs/ftpxferlog
    lrwxrwxrwx    1 root     root           41 Jan  9 23:30 xferlog.4 -> ../../usr/local/apache/domlogs/ftpxferlog
    -rw-r--r--    1 root     root            2 Feb  8 03:51 xferlog.offset
    -rw-r--r--    1 root     root            2 Feb  8 13:30 xferlog.offsetftpsep
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice