The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Proftpd passive mode hangs

Discussion in 'General Discussion' started by natong, Sep 8, 2011.

  1. natong

    natong Well-Known Member

    Joined:
    May 17, 2008
    Messages:
    85
    Likes Received:
    0
    Trophy Points:
    6
    [Solved] Proftpd passive mode hangs

    My WHM is on VPS.

    WHM 11.30.2 (build 1)
    CENTOS 5.6 i686 virtuozzo on host

    Someone recommend to add code into /etc/proftpd.conf
    Code:
    PassivePorts  50000 50500
    
    I also tried disable Windows Firewall and Kaspersky.
    But it still freeze when LIST -la
    Code:
    Entering Passive Mode (xx,xx,xx,xx,195,197).
    

    Code:
    proftpd -V
    Compile-time Settings:
      Version: 1.3.3e (maint)
      Platform: LINUX [Linux 2.6.18-028stab070.5 i686]
      Built: Tue Apr 5 2011 14:16:50 CDT
      Built With:
        configure  '--build=i686-redhat-linux-gnu' '--host=i686-redhat-linux-gnu' '--target=i386-redhat-linux-gnu' '--program-prefix=' '--datadir=/usr/share' '--libexecdir=/usr/libexec' '--localstatedir=/var' '--sharedstatedir=/usr/com' '--mandir=/usr/share/man' '--infodir=/usr/share/info' '--sysconfdir=/etc' '--sbindir=/usr/sbin' '--bindir=/usr/bin' '--prefix=/usr' '--exec-prefix=/usr' '--mandir=/usr/man' '--with-includes=/usr/kerberos/include' '--includedir=/usr/include' '--libdir=/usr/lib' '--libexecdir=/usr/libexec/proftpd' '--with-modules=mod_tls:mod_wrap:mod_sftp' '--disable-sendfile' '--enable-openssl' '--with-openssl-dir=/usr' '--enable-shadow' '--enable-dso' 'build_alias=i686-redhat-linux-gnu' 'host_alias=i686-redhat-linux-gnu' 'target_alias=i386-redhat-linux-gnu' 'CFLAGS=-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables'
    
      CFLAGS: -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables -Wall
      LDFLAGS: -L$(top_srcdir)/lib  
      LIBS:  -lssl -lcrypto -lssl -lcrypto -lcap  -lwrap -lnsl  -lssl  -lpam  -lcrypto -lz -lsupp -lcrypt -ldl  -ldl
    
      Files:
        Configuration File:
          /etc/proftpd.conf
        Pid File:
          /var/proftpd.pid
        Scoreboard File:
          /var/proftpd.scoreboard
        Header Directory:
          /usr/include/proftpd
        Shared Module Directory:
          /usr/libexec/proftpd
    
      Features:
        - Autoshadow support
        - Controls support
        + curses support
        - Developer support
        + DSO support
        + IPv6 support
        + Largefile support
        - Lastlog support
        + ncurses support
        - NLS support
        + OpenSSL support
        - POSIX ACL support
        + Shadow file support
        - Sendfile support
        + Trace support
    
      Tunable Options:
        PR_TUNABLE_BUFFER_SIZE = 1024
        PR_TUNABLE_DEFAULT_RCVBUFSZ = 8192
        PR_TUNABLE_DEFAULT_SNDBUFSZ = 8192
        PR_TUNABLE_GLOBBING_MAX_MATCHES = 100000
        PR_TUNABLE_GLOBBING_MAX_RECURSION = 8
        PR_TUNABLE_HASH_TABLE_SIZE = 40
        PR_TUNABLE_NEW_POOL_SIZE = 512
        PR_TUNABLE_SCOREBOARD_BUFFER_SIZE = 80
        PR_TUNABLE_SCOREBOARD_SCRUB_TIMER = 30
        PR_TUNABLE_SELECT_TIMEOUT = 30
        PR_TUNABLE_TIMEOUTIDENT = 10
        PR_TUNABLE_TIMEOUTIDLE = 600
        PR_TUNABLE_TIMEOUTLINGER = 30
        PR_TUNABLE_TIMEOUTLOGIN = 300
        PR_TUNABLE_TIMEOUTNOXFER = 300
        PR_TUNABLE_TIMEOUTSTALLED = 3600
        PR_TUNABLE_XFER_SCOREBOARD_UPDATES = 10
    
    When run modprobe ip_conntrack_ftp, I got
    Code:
    FATAL: Could not load /lib/modules/2.6.18-028stab070.5/modules.dep: No such file or directory
    
     
    #1 natong, Sep 8, 2011
    Last edited: Sep 8, 2011
  2. natong

    natong Well-Known Member

    Joined:
    May 17, 2008
    Messages:
    85
    Likes Received:
    0
    Trophy Points:
    6
    Yahoo. I solved.

    ------------------------------------------------------------------------------

    nano -w /etc/proftpd.conf
    Code:
    <Global>
    [COLOR="#FF0000"]PassivePorts 30000 30030[/COLOR]
    </Global>
    
    service proftpd restart

    nano -w /etc/sysconfig/iptables-config

    Code:
    IPTABLES_MODULES="[COLOR="#FF0000"]nf_conntrack_ftp[/COLOR]"
    
    service iptables restart
     
  3. Mysticeti

    Mysticeti Well-Known Member

    Joined:
    Sep 16, 2002
    Messages:
    45
    Likes Received:
    2
    Trophy Points:
    8
    Location:
    Southern NH
    Thanks! This solved my problem as well.
     
Loading...

Share This Page