The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Proftpd problem

Discussion in 'General Discussion' started by DHL, Mar 15, 2002.

  1. DHL

    DHL Well-Known Member

    Joined:
    Mar 8, 2002
    Messages:
    88
    Likes Received:
    0
    Trophy Points:
    6
    Hi,

    When I set my main domain up for my server I did the following:-

    Server: server.mydomain.com IP. 123.123.123.123
    Main Domain: mydomain.com IP. 123.123.123.124
    NS1 IP, 123.123.123.124
    NS2 IP. 123.123.123.125

    I also clicked on the 'ADD A RECORD FOR SERVER NAME'
    which added an A record 123.123.123.123 to my mydomain.com zone file.

    Problem I couldn't start proftpd - I just kept getting the error ' Can't locate IP address for server.mydomain.com - proftpd would not stop or start.

    OK, I added the following to /etc/hosts
    123.123.123.123 server.mydomain.com

    and restarted proftpd and it worked - It's now running, is this fixed or do I need to do something else?

    Any help, as always is appreciated.

    Steve
     
  2. bdraco

    bdraco Guest

    [quote:e184d65b4f][i:e184d65b4f]Originally posted by DHL[/i:e184d65b4f]

    Hi,

    When I set my main domain up for my server I did the following:-

    Server: server.mydomain.com IP. 123.123.123.123
    Main Domain: mydomain.com IP. 123.123.123.124
    NS1 IP, 123.123.123.124
    NS2 IP. 123.123.123.125

    I also clicked on the 'ADD A RECORD FOR SERVER NAME'
    which added an A record 123.123.123.123 to my mydomain.com zone file.

    Problem I couldn't start proftpd - I just kept getting the error ' Can't locate IP address for server.mydomain.com - proftpd would not stop or start.

    OK, I added the following to /etc/hosts
    123.123.123.123 server.mydomain.com

    and restarted proftpd and it worked - It's now running, is this fixed or do I need to do something else?

    Any help, as always is appreciated.

    Steve[/quote:e184d65b4f]

    Fixed /etc/resolv.conf so that the first nameserver points to 127.0.0.1
     
  3. DHL

    DHL Well-Known Member

    Joined:
    Mar 8, 2002
    Messages:
    88
    Likes Received:
    0
    Trophy Points:
    6
    Hi ,

    I checked my /etc/resolv.conf and found the following

    domain darkorb.net
    search darkorb.net
    nameserver 205.162.50.248
    nameserver 66.96.193.2
    nameserver 66.96.194.2

    These are not my IP's (The lower 2) what do I update this to?

    Bind reported a problem when the layer 2 installed automatically last night - I'm guessing that this happened then.
    Is it possible to disable the auto update? What are the consequences?

    Also there isn't a virtual host set up for server.mydomain.com only mydomain.com - Does there have to be?


    Cheers for the help.

    Regards

    Steve
     
  4. feanor

    feanor Well-Known Member

    Joined:
    Aug 13, 2001
    Messages:
    836
    Likes Received:
    0
    Trophy Points:
    16
    Put the nameservers that are SUPPOSED to be primary and secondary in /etc/resolv.conf

    (that is, what nameservers have the zones for the domains in your apache configuration)....

    Then, lock the file with &chattr +i /etc/resolv.conf& , so that cpanel nightly updates don't revert the file to reflecting a foreign network. You DON'T want to disable the auto-update completely.

    And yes, you'll want that &server.yourdomain.com& host configured..... make sure it resolves to the outside world as well! /scripts/ipcheck will help you with this.


    Good luck.
     
Loading...

Share This Page