The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

proftpd resume upload error

Discussion in 'Database Discussions' started by angel.white, Aug 23, 2006.

  1. angel.white

    angel.white Member

    Joined:
    Aug 2, 2006
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    hi, im uploading a 3GB database to my server, pure-ftpd cant upload more than 2GB so i switched to proftpd

    unfortunately my connection is slow (30-80kb upload) and so it takes about 30 hours. also unfortunately my isp blows and cant remain consistently up for that amount of time

    when i tried to resume with pure-ftpd it worked fine and i was able to get up to the 2GB limit before i ran into problems

    now that ive switched to proftpd, i try to resume, but it will not allow this, it says "Append/Restart not permitted, try again"

    some internet research showed me there is a config file called "proftpd.conf" that i can edit to allow restarting. everything i read indicated it should be located in "/etc/proftpd.conf" however in my "etc" folder there is no file called this, there are only 2 files called "ftpquota" and ".imapv4cp5c" both of which are 0kb

    i tried making my own config file with the information that they said i should have, and uploaded it to that directory and restarted my ftp, it did nothing, so i deleted the file

    can anyone please help me figure out how to enable the ftp resume option so that i can upload my database and get my site running again?

    thank you
     
  2. websupport

    websupport Well-Known Member

    Joined:
    Jun 24, 2006
    Messages:
    92
    Likes Received:
    0
    Trophy Points:
    6
    Locate proftpd.conf file

    Hello,

    Locate for proftpd.conf file.

    Add the following code into your proftpd.conf file:
    AllowStoreRestart on

    Location for proftpd.conf files may be

    /usr/local/ftpd/etc/proftpd.conf
    /usr/local/etc/proftpd.conf
    /etc/proftpd.conf


    :)
     
  3. angel.white

    angel.white Member

    Joined:
    Aug 2, 2006
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    thank you very much for the help, unfortunately i am still having difficulty locating the proftpd.conf file. it is not in the /etc folder and i dont seem to have a /usr folder

    here is an image showing my site structure, public_html is not expanded as it has many files & folders that i uploaded for the site itself (it does seem to have some system folders in it, but none are /usr)

    http://img237.imageshack.us/img237/9312/structureuj9.gif

    or a text representation since i dont seem to have image posting privelages



    /.cpanel-datastore

    /.trash

    /etc

    /mail
    /mail/cur
    /mail/new
    /mail/tmp

    /public_ftp
    /public_ftp/incoming

    /public_html
    /public_html/_private
    /public_html/_vti_bin
    /public_html/_vti_bin/_vti_adm
    /public_html/_vti_bin/_vti_aut
    /public_html/_vti_cnf
    /public_html/_vti_log
    /public_html/_vti_pvt
    /public_html/_vti_txt
    /public_html/(lots of folders i uploaded that arent hosting related)

    /tmp
    /tmp/analog
    /tmp/awstats
    /tmp/cpbandwidth
    /tmp/webalizer
    /tmp/webalizerftp

    /www
     
  4. angel.white

    angel.white Member

    Joined:
    Aug 2, 2006
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    it might be worth pointing out that i did not install this software, it came bundled in my cpanel which i was told would be best for the transition to a vps after my site got too large for shared server
     
  5. websupport

    websupport Well-Known Member

    Joined:
    Jun 24, 2006
    Messages:
    92
    Likes Received:
    0
    Trophy Points:
    6
    Install proftpd rpm

    Hello,

    I think proftpd RPM is not installed on your server.

    Firstly download the proftpd RPM from ftp.linuxppc.org:
    ftp ftp.linuxppc.org/linuxppc-2000/software/proftpd-1.2.0pre9-1a.ppc.rpm
    And install that rpm on server and then edit the /etc/proftpd.conf file.

    :)
     
  6. angel.white

    angel.white Member

    Joined:
    Aug 2, 2006
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    thank you, i have it downloaded, and am trying to figure out how to install currently

    here is a screenshot of my cpanel that indicates to me that i already have it installed and running (i put a red box around it)
    http://img226.imageshack.us/img226/5144/proftpdbc3.jpg


    the documentation on the install assumes i know something that i do not know :(
    it says "The Linux RPM package is available on the main distribution sites for Proftpd. Installation is as simple as rpm --install proftpd-{version}.rpm" (reference: http://www.proftpd.org/localsite/Userguide/linked/x146.html)

    based on the format they have put it in, it sounds like there is some command line tool i need to use. i think perhaps ssh? (i believe this is a command line tool, though its unfortunate i would have to go in with no knowledge and learn a system so that i can go in with no knowledge to learn another system so that i can do something i should be able to do anyway)

    *sigh* the amount of effort that is required to upload 1 file is so terribly daunting
     
    #6 angel.white, Aug 23, 2006
    Last edited: Aug 23, 2006
  7. websupport

    websupport Well-Known Member

    Joined:
    Jun 24, 2006
    Messages:
    92
    Likes Received:
    0
    Trophy Points:
    6
    Run scripts from shell

    Run the script /scripts/fixproftpddupes to Updates proftpd.

    Or

    run the script /scripts/rebuildproftpd to Restore proftpd.conf from httpd.conf

    :)
     
  8. angel.white

    angel.white Member

    Joined:
    Aug 2, 2006
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    my host told me that they can see it in that folder

    however i only have 2 files in that folder, .imapv4cp5c and ftpquota, both of which are 0kb. could this file somehow be hidden from me?

    and his "ls -la /etc/proftpd.conf" is most definately command line, can someone tell me what software i need to have to be able to log onto my server and access it as the support guy did?
     
  9. angel.white

    angel.white Member

    Joined:
    Aug 2, 2006
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    ok, heres the rundown for anyone reading this thread with a similar issue

    premise: you must be running cpanel's WHM (Web Host Manager) & virtuozzo.
    at the top right of my WHM it says: WHM 10.8.0 cPanel 10.8.2-R119
    CentOS 4.3 i686 - WHM X v3.1.0
    which is probably a version, but is confusing to me, but if yours is different then there might be some nuances to your version that my solutions do not cover

    problem1: could not upload more than 2GB of any file
    reason1: i was using pure-ftpd which apparently blows
    solution1: switch to proftpd. in your WHM go to "Service Configuration" (in the left frame) and click the subcategory "FTP Configuration" it will load a screen in the right frame, at the top it will say "Tweak Ftp Settings" then below that "Installed Ftp Server" and in the box below that it will say pure-ftpd with a button below it that says "Switch to proftpd" click that button. you should now be running proftpd rather than pure-ftpd.

    problem2: my isp sucks and cant stay up for the 30+ hours required to upload the file, and the ftp refuses to resume
    reason2: there is a setting that must be edited in the configuration file to allow restarts on uploads
    solution2: edit the file to add the required code. on your site navigate to /etc/proftpd.conf edit that file. find the code
    Code:
    # Normally, we want files to be overwriteable.
    <Directory />
      AllowOverwrite		on
    </Directory>
    and change it to look like this
    Code:
    # Normally, we want files to be overwriteable.
    <Directory />
      AllowOverwrite		on
     AllowStoreRestart            on
    </Directory>
    this setting will allow you to resume a broken upload
    at this point i also restarted my ftp, im not sure if you need to or not, but i did and it worked for me, so to restart your ftp go to your WHM, find "Restart Services" in the left frame, find the subcategory "FTP Server (ProFTPd/PureFTPd)" click that, it will ask you if you really want to restart the service, click yes, it will diddle around a bit and say its good (if it says its bad, you probably screwed up your config file, just undo whatever you did and try again) once it says its good, reload your ftp software and you should be able to continue uploading where you left off

    problem3: in order to edit my config file i need access to it, but my ftp was showing basically nothing under my "etc" folder
    reason3: apparently even though i was on the main account of my ftp it still did not have adequate privileges
    solution3: supposedly theres some ridiculously confusing and difficult command line tool called SSH that people just assume you have. well good news, you dont need to go bang your head on a rock like i've been doing last half a day trying to get it to work, you can completely bypass it alltogether. log into your virtuozzo (my hosts called it "power panel") this will basically give you total access to your site without having to go through all the headache confusion of making new accounts with funky privelages and such. once in there in the left pane find "VPS Management" and click the subdirectory "File Manager" this will show you all the files in your site (you will probably notice immediately that there are more than you see in your ftp). now you can navigate to the "etc" folder, and it will show you a ton of files. find the file "proftpd.conf" and click the far right icon, it should look like a pad of paper with a pencil writing on it. this is the edit icon. it will allow you to edit it right there without having to download, edit, and upload. then make the changes indicated in solution2 and save it and restart the ftp.

    possible future error: proftpd should be able to exceed the 2GB limit of pure-ftpd, however i have not gotten there yet to verify (however i have verified resume upload)

    i believe that covers everything, hopefully someone as ignorant as i am with a similar problem can come and find some help

    and seriously though, screw ssh, i cant believe i wasted so much time trying to figure out how that nonsense works

    oh, and i would have embedded images to help illustrate the steps and make it clearer, but either all images are forbidden (which seems foolish to me, so i doubt this is the case) or someone thought it would be funny to revoke my image posting privilages, not sure. but hopefully you can figure it out from what i've posted, if not, too bad, spend 3 days trying to figure it out like i have
     

Share This Page