The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

public_html folder missing

Discussion in 'General Discussion' started by Markwaugh, Dec 20, 2003.

  1. Markwaugh

    Markwaugh Well-Known Member

    Joined:
    Aug 12, 2003
    Messages:
    151
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Sydney, Australia
    Hello,

    I checked my file manager and i noticed that my public_html folder is missing. www says that "File Type: broken symbolic link to public_html" and www shows that it is a file and NOT a folder. I could not locate public_html folder anywhere.

    I do not have ssh (root) access to the server, but i have access only to the Cpanel.

    any ideas would be highly appricated !!
     
  2. Website Rob

    Website Rob Well-Known Member

    Joined:
    Mar 23, 2002
    Messages:
    1,506
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    Alberta, Canada
    cPanel Access Level:
    Root Administrator
    As www is a symbolic link to public_html, not having one will generate an error. Seems really odd though, that it went missing???

    You can create another one, with your FTP program or File Mgr. (permission of 750 should work) but I have to wonder -- how do you access your site if you do not have a public_html dir.?
     
  3. PWSowner

    PWSowner Well-Known Member

    Joined:
    Nov 10, 2001
    Messages:
    2,948
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    ON, Canada
    I doubt he has access to his site, but if he does, something is really weird.

    Like Rob said, you will need to recreate your public_html folder. Permissions and ownership should be either
    750 username:cpanel - new defaults
    or
    755 username:username - old defaults

    Does cpanel show the folder? It could just be wrong permissions. If it is gone, that means your site is gone too and you may want to figure out how it disappeared.
     
  4. Markwaugh

    Markwaugh Well-Known Member

    Joined:
    Aug 12, 2003
    Messages:
    151
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Sydney, Australia
    Hi,

    Nope.... site was not working ...... I created a public_html folder with 755 permission and it worked and you know www was a file previously and i had to create another www folder and create a symlink for it and the site works now.

    Thank you for your time.
     
Loading...

Share This Page