Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

public_html keeps resetting to 750

Discussion in 'General Discussion' started by Snowman30, Nov 25, 2003.

  1. Snowman30

    Snowman30 Well-Known Member
    PartnerNOC

    Joined:
    Apr 7, 2002
    Messages:
    679
    Likes Received:
    0
    Trophy Points:
    316
    cPanel Access Level:
    DataCenter Provider
    Despite setting all users public_html folders to 755 they seem to keep swapping back to 750 which gives a permission denied error when trying to view the site.

    Can anyone tell me a fix to stop this happening??
     
  2. [Q3]

    [Q3] Member

    Joined:
    Apr 8, 2003
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    151
    I have this problem too.
    I had to set 777 to the home folder to make it work.
    But it is really not secure ?

    Anyone got a idea?
     
  3. Marty

    Marty Well-Known Member

    Joined:
    Oct 10, 2001
    Messages:
    630
    Likes Received:
    1
    Trophy Points:
    318
    Recompile apache without Enable File Protect and then ssh to the box and:

    cd /var/cpanel

    if there is a file there named fileprotect, remove it, then

    chmod 755 /home/*/public_html

    That should solve it.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice