Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Pure-FTP client not connecting error

Discussion in 'General Discussion' started by Thiago Moreira, Jun 21, 2016.

Tags:
  1. Thiago Moreira

    Joined:
    Jun 21, 2016
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Brazil
    cPanel Access Level:
    Root Administrator
    I'm trying to connect to one of the customers and none of them are connecting FTP, which can is occurring?

    Status: The start TLS ...
    Status: Verifying certificate ...
    Status: TLS connection established.
    Status: Logged in
    State: Getting folder list ...
    Command: PWD
    Response: 257 "/" is your current location
    Command: TYPE I
    Response: 200 TYPE is now 8-bit binary
    Command: PASV
    Response: 227 Entering Passive Mode (64,187,229,2,217,117)
    Command: MLSD
    Error: Connection timed out after 20 seconds of inactivity
    Error: Failed to get the folder list
     
  2. mtindor

    mtindor Well-Known Member

    Joined:
    Sep 14, 2004
    Messages:
    1,344
    Likes Received:
    58
    Trophy Points:
    178
    Location:
    inside a catfish
    cPanel Access Level:
    Root Administrator
    1. Make sure /etc/pure-ftpd.conf has PassivePortRange uncommented

    ex:

    PassivePortRange 30000 35000

    2. Make sure your firewall is allowing access over the passive port range

    If you are using ConfigServer Firewall (CSF), then you would set up in /etc/csf/csf.conf like this:

    TCP_IN = "20,21,25,26,53,80,110,143,443,465,587,967,993,995,2077,2078,2082,2083,2086,2087,2095,2096,30000:35000"


    NOTE: The passive port numbers are somewhat arbitrary. If "PassivePortRange" is commented out in your /etc/pure-ftpd.conf, the port range is probably different. That is okay. You just need to uncomment PassivePortRange in /etc/pure-ftpd.conf (and run /scripts/restartsrv_pureftpd) and then add that same port range to TCP_IN= in /etc/csf/csf.conf and then run 'csf -r' to restart CSF.

    If you are using some other firewall, you will have to make sure that you have allowed the passive port range in on your firewall.

    mike
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    TCB13 likes this.
  3. ssfred

    ssfred Well-Known Member

    Joined:
    Jan 6, 2012
    Messages:
    64
    Likes Received:
    4
    Trophy Points:
    58
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello :)
    As mentioned in the previous reply, firewalls are the major possibility for such issues. Since FileZilla uses FTP over TLS by default, If the server isn't configured correctly for explicit FTP over TLS, then the error can occur. As a workaround you may change the connection settings to plain FTP connection or SFTP. You can set it by switching the "Encryption" settings present in Site Manager in FileZilla.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,704
    Likes Received:
    1,883
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice