The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Pure Ftp Error

Discussion in 'General Discussion' started by bonnmac, Jun 3, 2003.

  1. bonnmac

    bonnmac Well-Known Member

    Joined:
    Apr 26, 2003
    Messages:
    101
    Likes Received:
    0
    Trophy Points:
    16
    Hi I have a client who just sent me this email. I have looked everywhere I know of to find the problem I even restarted to ftp server thinking it would disconnect anyone who was connected but it still didn't work. Any ideas where/what I should look for? Thanks.

    Here's the error....



    quote:
    --------------------------------------------------------------------------------
    STATUS:> Host name ftp.domain.com resolved: ip = **.***.***.***.

    STATUS:> Getting listing ""...

    STATUS:> Connecting to ftp server ftp.domain.com:21 (ip = **.***.***.***)...

    STATUS:> Socket connected. Waiting for welcome message...

    421 Too many connections (3) from this IP

    ERROR:> Service unavailable. Try again later.

    don't understand , im not even connected and the ftp session thing in cpanel shows none
    --------------------------------------------------------------------------------

    cPanel.net Support Ticket Number:
     
  2. jameshsi

    jameshsi Well-Known Member

    Joined:
    Oct 22, 2001
    Messages:
    347
    Likes Received:
    0
    Trophy Points:
    16
    I got this "Too many connections (3) from this IP" too.
    Why ?
    If all my staffs working on the same project and using the same ftp from same IP, we will be blocked ?
    Is there a way to change the setting ?

    cPanel.net Support Ticket Number:
     
  3. Jemshi

    Jemshi Well-Known Member

    Joined:
    Sep 11, 2003
    Messages:
    210
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    try restarting ftp server.

    cPanel.net Support Ticket Number:
     
  4. ciphervendor

    ciphervendor Well-Known Member

    Joined:
    Aug 26, 2002
    Messages:
    1,052
    Likes Received:
    0
    Trophy Points:
    36
    edit: /etc/sysconfig/pure-ftpd
    find: --maxclientsperip=3
    Increase 3 to whatever.
    Save & close.
    service pure-ftpd restart

    cPanel.net Support Ticket Number:
     
  5. nickn

    nickn Well-Known Member
    PartnerNOC

    Joined:
    Jun 15, 2003
    Messages:
    619
    Likes Received:
    1
    Trophy Points:
    18
    Warning...I played with the /etc/sysconfig/pure-ftpd, and it didn't do to well afterwards ;)

    cPanel.net Support Ticket Number:
     
  6. ciphervendor

    ciphervendor Well-Known Member

    Joined:
    Aug 26, 2002
    Messages:
    1,052
    Likes Received:
    0
    Trophy Points:
    36
    You should probably know what you're doing before you start editing daemon config files. I didn't think that a warning was necessary but apparently is.

    cPanel.net Support Ticket Number:
     
  7. nickn

    nickn Well-Known Member
    PartnerNOC

    Joined:
    Jun 15, 2003
    Messages:
    619
    Likes Received:
    1
    Trophy Points:
    18
    I know very well what I'm doing, however, the way Cpanel does some things, running cpanel systems a whole lot different than editting a file on a non-cpanel system with pureftpd :)

    cPanel.net Support Ticket Number:
     
  8. wipl_piyush

    wipl_piyush Well-Known Member

    Joined:
    Oct 31, 2003
    Messages:
    66
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    NY
    Dear ciphervendor ,

    Thank you very much for this.......i am grate full to you.
     
  9. apodigm

    apodigm Well-Known Member

    Joined:
    May 12, 2003
    Messages:
    67
    Likes Received:
    0
    Trophy Points:
    6
    Having this same problem. But I've got one customer using WSFTP and everything works fine. In fact, the only customer that is having this problem is using CuteFTP. Can anyone shed some light on that?


    Also, I looked at the message log and I see a HUGE number of FTP connections from 127.0.0.1. In the past, I've ignored these as being CP-wrapper related, but I wonder if this is different. the xferlog doesn't show any 127.0.0.1. It looks like the connection are every 7 or 8 minutes. And.... it all just started on Jun 20th!....

    Here's what they look like:
    Jun 20 04:08:42 [server] pure-ftpd[31914]: (?@127.0.0.1) [INFO] New connection from 127.0.0.1
    Jun 20 04:08:42 [server] pure-ftpd[31914]: (?@127.0.0.1) [INFO] Logout - CPU time spent: 0.000 seconds.
     
  10. Annette

    Annette Well-Known Member
    PartnerNOC

    Joined:
    Aug 12, 2001
    Messages:
    445
    Likes Received:
    0
    Trophy Points:
    16
    That's your server checking in (WHM status, chkservd) to make sure FTP is running.
     
  11. apodigm

    apodigm Well-Known Member

    Joined:
    May 12, 2003
    Messages:
    67
    Likes Received:
    0
    Trophy Points:
    6
    great.

    But was it just added this past Sunday? I did a grep on my messages log and I don't see anything prior than Jun 20.

    Thanks!
     
Loading...

Share This Page