The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

pure ftp ftpserver has failed, please contact the sysadmin - SOLVED

Discussion in 'General Discussion' started by craigedmonds, Jun 2, 2011.

  1. craigedmonds

    craigedmonds Well-Known Member

    Joined:
    Oct 29, 2007
    Messages:
    107
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Europe
    cPanel Access Level:
    Root Administrator
    Twitter:
    In the middle of the night last night, pureftpd service went down.

    We tried restarting the ftp service and got the following error: pure ftp ftpserver has failed, please contact the sysadmin.

    So after searching around and trying all the usual stuff like switching over to proftp, reinstalling both ftp servers, disabling firewalls, checking host access...etc....one of my guys after a few hours found the issue.

    We really hope this helps someone.
     
  2. lbeachmike

    lbeachmike Well-Known Member

    Joined:
    Dec 27, 2001
    Messages:
    313
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Long Beach, NY
    cPanel Access Level:
    Root Administrator
    Mission accomplished Craig! This totally helped me out!

    Though this appears to be due to a cpanel bug which I am able to reproduce - I made a change via WHM -> FTP Server Configuration (which does not have CallUploadScript) and that appears to cause it to add in the CallUploadScript yes setting, thus causing the failure. I will report this behavior via ticket.

    Thanks very much!

    Mike
     
  3. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Hello Mike,

    This wouldn't be a cPanel bug. There is a program that is called ftp_clamscan (and possibly others) that will edit /var/cpanel/conf/pureftpd/main file to add "CallUploadScript yes" and cause this to occur. cPanel doesn't automatically have that line at all in /var/cpanel/conf/pureftpd/main file and only another program would add it.

    Once /var/cpanel/conf/pureftpd/main is edited to add lines, then anytime you revise FTP Server Configuration area, it will re-add the lines from that configuration file. Simply remove the custom line from /var/cpanel/conf/pureftpd/main and go back to WHM > FTP Server Configuration area again, save the settings there and it will add a properly generated /etc/pure-ftpd.conf file at that point.

    Thanks!
     
Loading...

Share This Page