The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Pure-ftp with IE7 issue

Discussion in 'General Discussion' started by carock, Oct 29, 2007.

  1. carock

    carock Well-Known Member

    Joined:
    Sep 25, 2002
    Messages:
    232
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    St. Charles, MO
    I have a customer that cannot login to their FTP site with IE7 now. This has happened since I upgraded from ProFTPD to Pure-FTP.

    Looking at the message log, I see this error.

    [ERROR] Unable to set up secure anonymous FTP

    I guess Internet Explorer tries to login with anonymous first before prompting you for login credentials? At least that's how it seemed to work when ProFTPD was running.

    The browser just gives a page cannot be displayed error now and there's no place to enter login credentials for the FTP connection in IE.

    I have another server still running ProFTPD and IE will prompt you for login credentials when you try to connect to ftp://www.sitename - PureFTPD will not.

    Does anyone have any ideas to "fix" this on one end or the other?

    Thanks,
    Chuck
     
  2. mtindor

    mtindor Well-Known Member

    Joined:
    Sep 14, 2004
    Messages:
    1,281
    Likes Received:
    37
    Trophy Points:
    48
    Location:
    inside a catfish
    cPanel Access Level:
    Root Administrator
    They probably need to type in:

    ftp://accountname@www.theirwebsite.com

    This will force it to prompt for a login/password box that will have 'accountname' already filled in and allow them to specify their password.

    Mike


     
  3. sarhosting

    sarhosting Well-Known Member

    Joined:
    Oct 1, 2007
    Messages:
    164
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    United States
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hi there,

    When you go to: ftp://ftp.domain.com you get the "cannot login in via anoymous blah blah"

    Simply right click then click login in as >> however I wouldnt reccomend using IE 7 for FTP as you can uplaod files through it, just browse them

    However: Use Windows Explorer:

    ftp.domain

    user
    pass

    then same again after the message and then right click and login as.

    Regards
     
  4. kvihosting

    kvihosting Registered

    Joined:
    Jul 10, 2002
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Internet Explorer 7 doesn't show any login box.

    I found the following posting on the Pure-FTPd website in their documentation page (http://download.pureftpd.org/pub/pure-ftpd/doc/FAQ):

    IE does a very strange trick to detect whether an FTP server does accept
    anonymous connections or not. Basically, it connects to the server and logs
    in as 'anonymous'. But if you say 'no' at this point, it drops the
    connections with an error. You have to say 'ok, anonymous users are
    allowed' and then, when a dummy password ('IE..at..') is sent, you say 'ah
    ehm... finally... no... anonymous users aren't allowed' . Silly. To play
    that game, you must run pure-ftpd with the -E (non-anonymous server) and -b (compatibility with broken clients) flags. Then, the magic popup will show
    up. But please note that IE (and browsers at large) are usually bad FTP
    clients.

    I modified my /etc/rc.d/init.d/pure-ftpd file and added the -E and -b on the line that starts Pure-FTPd and that solved the problem.

    Dan
     
  5. sneader

    sneader Well-Known Member

    Joined:
    Aug 21, 2003
    Messages:
    1,126
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    La Crosse, WI
    cPanel Access Level:
    Root Administrator
    Dan kvihosting... you are on the right track with fixing the problem, but I think you are making the solution more difficult than it needs to be.

    Your solution to enable support for broken clients fixed the problem for me, but here is how I did it:

    1) Edit /etc/pure-ftpd.conf

    2) Find these lines of the config
    Code:
              # Turn on compatibility hacks for broken clients
              BrokenClientsCompatibility no
    3) Change no to yes

    4) Restart PureFTP (I use WHM's Restart feature)

    Done.

    - Scott
     
  6. Svintoo

    Svintoo Member

    Joined:
    Apr 16, 2009
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    Thank you sneader.

    I had the same problem and tried to fix it by editing init.d.
    Editing the configuration file for pure-ftpd is a much better solution.
     
Loading...

Share This Page