Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

pure-ftpd /etc/ftpusers blocking doesn't work

Discussion in 'General Discussion' started by jamesbond, Jul 25, 2005.

  1. jamesbond

    jamesbond Well-Known Member

    Joined:
    Oct 9, 2002
    Messages:
    738
    Likes Received:
    1
    Trophy Points:
    168
    Since I switched to Pure-FTPD I noticed the users listed in /etc/ftpusers are allowed to log in, instead of blocked.

    Does blocking users require a different method with pureftpd (compared to proftpd) ?
     
  2. nickb

    nickb Well-Known Member

    Joined:
    Feb 25, 2005
    Messages:
    347
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    India
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. jamesbond

    jamesbond Well-Known Member

    Joined:
    Oct 9, 2002
    Messages:
    738
    Likes Received:
    1
    Trophy Points:
    168
    Thanks, I might try that. Although it seems that pam authentication is disabled by default in pure-ftpd.

    From /etc/pure-ftpd.conf

    Code:
     
    # If you want to enable PAM authentication, uncomment the following line
    
    # PAMAuthentication             yes
    
    I don't really understand why it has to be so complicated to block users in pure-ftpd.
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice