Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

pure-ftpd failing each minute!! help!

Discussion in 'General Discussion' started by bsasninja, Apr 24, 2007.

  1. bsasninja

    bsasninja Well-Known Member

    Joined:
    Sep 2, 2004
    Messages:
    528
    Likes Received:
    0
    Trophy Points:
    166
    Im using Cpanel/WHM 10.9.0-RELEASE_9808.

    ftpd at Whm service status is in red (failed state) but ftp is working cause I can log to ftp and upload/download files.

    I did a service pure-ftpd restart , /etc/init.d/pure-ftpd restart and nothing

    Also I run service chkservd restart and stills is in red.

    Which is the problem????????? :eek:

    This is what i have in /var/log/messages

    Apr 24 11:57:58 server pure-config.pl: Running: /usr/sbin/pure-ftpd -O clf:/var/log/xferlog -lextauth:/var/run/ftpd.sock --daemonize -A -c30 -B -C2 -D -E -fftp -H -I10 -lextauth:/var/run/ftpd.sock -L2000:8 -m4 -p30000:50000 -s -Sxxx.xx.xx.xxx,21 -T10 -U133:022 -u100 -Oxferlog:/usr/local/apache/domlogs/ftpxferlog -k99 -Z -Y1
    Apr 24 11:57:58 server pure-ftpd: pure-config.pl startup succeeded
    Apr 24 12:03:28 server pure-config.pl: Running: /usr/sbin/pure-ftpd -O clf:/var/log/xferlog -lextauth:/var/run/ftpd.sock --daemonize -A -c30 -B -C2 -D -E -fftp -H -I10 -lextauth:/var/run/ftpd.sock -L2000:8 -m4 -p30000:50000 -s -Sxxx.xx.xx.xxx,21 -T10 -U133:022 -u100 -Oxferlog:/usr/local/apache/domlogs/ftpxferlog -k99 -Z -Y1
    Apr 24 12:03:28 server pure-ftpd: pure-config.pl startup succeeded
    Apr 24 12:06:22 server pure-config.pl: Running: /usr/sbin/pure-ftpd -O clf:/var/log/xferlog -lextauth:/var/run/ftpd.sock --daemonize -A -c30 -B -C2 -D -E -fftp -H -I10 -lextauth:/var/run/ftpd.sock -L2000:8 -m4 -p30000:50000 -s -Sxxx.xx.xx.xxx,21 -T10 -U133:022 -u100 -Oxferlog:/usr/local/apache/domlogs/ftpxferlog -k99 -Z -Y1
    Apr 24 12:06:22 server pure-ftpd: pure-config.pl startup succeeded

    Where xxx.xx.xx.xxx is my ip.
     
    #1 bsasninja, Apr 24, 2007
    Last edited: Apr 24, 2007
  2. mickalo

    mickalo Well-Known Member

    Joined:
    Apr 16, 2002
    Messages:
    778
    Likes Received:
    4
    Trophy Points:
    318
    Location:
    N.W. Iowa
    usually restarting the 'chkservd' daemon will correct this: service chkservd restart

    Mickalo
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. mickalo

    mickalo Well-Known Member

    Joined:
    Apr 16, 2002
    Messages:
    778
    Likes Received:
    4
    Trophy Points:
    318
    Location:
    N.W. Iowa
    make sure that IP address can access Port 21 ... possibly a firewall issue? We've used a specific IP w/pure-ftpd for sometime w/o problems.

    Mickalo
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. bsasninja

    bsasninja Well-Known Member

    Joined:
    Sep 2, 2004
    Messages:
    528
    Likes Received:
    0
    Trophy Points:
    166
    Exim is failing when I use the Bind option of it, cause I want to bind it to a specific ip address and not to ALL the ip in the server.

    If i
    Bind it to 200.xx.xx.xx,21 fails

    If i comment Bind line at /etc/pure-ftpd.conf, the service doesnt fails but all address in the server are allowed for connect.

    Why is failing when I bind to a specific ip to listen??
     
  5. bsasninja

    bsasninja Well-Known Member

    Joined:
    Sep 2, 2004
    Messages:
    528
    Likes Received:
    0
    Trophy Points:
    166
    Well the IP is the same main shared ip of the server. So its enabled, also port 21 in/out is enabled at the firewall.

    But I repeat the ftp server is working only it gives me a failed state when I enable bind at the config.

    Im confused.
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice